4

When I try to do video chatting in Firefox (using Jitsi Meet) it apparently selects the first available Input Source as my microphone which is always invalid. The one selected is "Monitor of HDMI Output" and that one is silent.

Normally I open pavucontrol and select the correct Input Source "Mic Input" in the Recording tab for the Firefox application. However, sometimes this does not work. Also, from within Firefox the Mic source is often not selectable / the selection has no effect. I need to select within pavucontrol.

Can I disable or blacklist the Pulse Audio channel "Monitor of HDMI Output" as a valid input/recording source for Firefox? Perhaps within Firefox itself?

If this source were hidden I would expect Firefox to behave much better within Jitsi Meet.

EDIT/Update:

The inability to select sound inputs in Firefox is a bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=934425

Also, this comment in this bug

https://bugzilla.mozilla.org/show_bug.cgi?id=1468700#c14

suggests that an audio input device cannot be changed while a different is active. This would explain why you cannot select the correct device once the wrong one has been selected.

However, this is at best an explanation, neither a workaround or a solution.

0

Firefox is setting up the streams with DONT_MOVE flag, which explains why you can't change them. The flag was not intended for regular apps to use, but it is nonetheless abused by some.

You can check this with pacmd:

 20:47 ❱ pacmd list-source-outputs
1 source output(s) available.
    index: 35
        driver: <protocol-native.c>
        flags: DONT_MOVE START_CORKED
        state: RUNNING

I suppose Firefox does that to avoid giving access to a device a user didn't acknowlegde, for example when the current device gets disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.