0

Recently on my android device I installed Arch via proot on termux but when I run the installation and enter bash it tells me that it cannot set the terminal process group and that it has no control of the shell.

Also when I try to run sudo it complains that it needs to be in a terminal to get my password. I get around this by using -S but it gets very annoying.

I assume that I need to be inside a terminal and not a shell but do not know how to enter the terminal from the shell. I'm not a very experienced with this sort of stuff to be honest and am very stumped any help would be appreciated.

The error occurs upon logging in to the user account via the login command from root.

[root00:00:home]$ login user
Password: 
Last login: Fri Jun 19 00:00:00 on stdout
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
0

I worked it out, instead of using the login command I had to use su.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.