I have a problem with my WiFi card on Kubuntu. Sometimes the system doesn't recognise it, but what is strange is that it doesn't happen everytime, but just about one boot on four, and I can't understand why. If I run lshw -C network I get:

*-network UNCLAIMED       
       description: Network controller
       product: Wireless 8265 / 8275
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 78
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:ef200000-ef201fff
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 15
       serial: 4c:ed:fb:07:64:b1
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:d000(size=256) memory:ef104000-ef104fff memory:ef100000-ef103fff

Do anyone know how to make it work steadly?

  • 1
    You should usually see log entries in syslog (/var/log/messages|syslog) or dmesg that may reveal something, or it could be that the network card is broken if it doesn't happen always.
    – eblock
    Jun 19, 2020 at 12:55
  • The card isn't broken because with Windows it works perfectly. It looks like a driver issue but I can't find a way to solve it. It seems like sometimes it manages to load it and some other times not Jun 19, 2020 at 13:02
  • what is output of dmesg | grep iwlwifi when it cannot recognise?
    – binarysta
    Jun 19, 2020 at 13:16
  • There's a chance that the kernel regonizes something even though it can't access it.
    – eblock
    Jun 19, 2020 at 13:16
  • @binarysta I tried and I got this: dmesg | grep iwlwifi [ 6.540045] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002) [ 7.388211] iwlwifi: probe of 0000:03:00.0 failed with error -110 Jun 19, 2020 at 14:04

1 Answer 1


If you have a dual-boot machine with a recent version of Windows and started seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

dmesg | grep iwlwifi

[    6.540045] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002)
[    7.388211] iwlwifi: probe of 0000:03:00.0 failed with error -110

With this feature enabled, Windows don't really shut down the entire system, but leaves things partially running so you can start the machine faster again.

Try to disable this option. on Windows 10 go to Control Panel→Hardware and Sound→Power Options→System Settings, then disable the Fast Startup option in Shutdown Settings. This will cause Windows to fully shutdown and may solve the issue.

EDIT: To get to System Settings from the Power Options screen, you may have to click "Choose what closing the lid does".

  • I had never seen such a solution elsewhere. Thanks, I try to see if it works Jun 19, 2020 at 14:38
  • FINALLY!! If it's not a casuality, it looks like it really worked! I've been searching for this solution for a long time! Thank you so much man, it was really annoying. Jun 19, 2020 at 14:54
  • @BernardBorio GREAT!!
    – binarysta
    Jun 19, 2020 at 15:07
  • @BernardBorio If this worked for you, please consider accepting this answer.
    – Freddy
    Jun 19, 2020 at 16:12
  • Thank you, this answer was really close. I have Ubuntu 20.04 and Windows installed alongside. After the first time I logged into Windows, I got exactly the same config as the TS - wireless unclaimed. I tried switching off fast startup in Windows, but there was no option "system settings" in "Power options". However I tried a simple thing and it worked - I just turned off Wi-Fi in Windows and restarted to Ubuntu. Solved
    – Matty
    Sep 9, 2020 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .