When I executed a command to install an application, the following error occurred

  /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

I was not aware on how to fix this problem. I found the following solution online:

yum install glibc.i686


yum install glibc.i386

But bad luck, this did not work at all. It was throwing the following error:

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
Setting up Install Process
No package glibc.i686 available.
Error: Nothing to do

Again I tried to resolve this and got some solutions from net

Download glibc rpm packge for centos 6 and install them.

I downloaded the following packages:


And tried to install with following command:

yum install glibc.i686
rpm -U glibc-2.12-1.80.el6.i686.rpm
rpm -ivh glibc-2.12-1.80.el6.i686.rpm

None of them solved my problem. I got following message:

[root@s7 tmp_glibc]# rpm -ivh glibc-2.12-1.80.el6.i686.rpm
    error: Failed dependencies:
    glibc-common = 2.12-1.80.el6 is needed by glibc-2.12-1.80.el6.i686
    libfreebl3.so is needed by glibc-2.12-1.80.el6.i686
    libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.80.el6.i686

To resolve the dependency problem I tried to install "glibc-common-2.12-1.80.el6.i686.rpm", but again bad luck runs and gives error:

[root@s7 tmp_glibc]# rpm -ivh glibc-common-2.12-1.80.el6.i686.rpm
error: Failed dependencies:
    glibc = 2.12-1.80.el6 is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6 is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.0) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.1) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.1.1) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.1.3) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.10) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.2) is needed by glibc-common-2.12-1.80.el6.i686
    libc.so.6(GLIBC_2.3) is needed by glibc-common-2.12-1.80.el6.i686
    libcap.so.2 is needed by glibc-common-2.12-1.80.el6.i686
    libdl.so.2 is needed by glibc-common-2.12-1.80.el6.i686
    libdl.so.2(GLIBC_2.0) is needed by glibc-common-2.12-1.80.el6.i686
    libdl.so.2(GLIBC_2.1) is needed by glibc-common-2.12-1.80.el6.i686

Can anyone please help me by resolving this issue?

More Details: Operating System: centos 6.3 Yum installed packege list:

[root@s7 tmp_glibc]# yum list installed glibc
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
Installed Packages
  • What application did you try to install in the first place by the way?
    – Bernhard
    Dec 25, 2012 at 8:48

2 Answers 2


Try first to search for the package:

yum search glibc

This will provide all the packages that contain glibc. Second, what application are you installation that gives you the error?

you can also perform the following

yum whatprovides /lib/ld-linux.so.2

This will tell you what package contains the required file so you can just issue yum install


just had same problem with android sdk on 64 bit centos 6 For me it worked this way:

wget ftp://fr2.rpmfind.net/linux/centos/6.3/os/i386/Packages/glibc-common-2.12-1.80.el6.i686.rpm
wget ftp://fr2.rpmfind.net/linux/centos/6.3/os/i386/Packages/glibc-2.12-1.80.el6.i686.rpm
yum install nss-softokn-freebl-3.12.9-11.el6.i686
rpm -Uhv glibc-2.12-1.80.el6.i686.rpm glibc-common-2.12-1.80.el6.i686.rpm

Also to make adnroid sdk working I had to install:

yum install zlib-1.2.3-27.el6.i686 libstdc++-4.4.6-4.el6.i686

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.