1

In my .bashrc, I set the TERMINAL variable:

export TERMINAL=termite

as a result, i3's exec i3-sensible-terminal can find my terminal emulator (termite) and open it when I press $mod+Return. However, for some reason, xterm is still started when i3 starts, as the status terminal that prints messages from i3. I start i3 with xinit i3, which I type in to my textmode shell when I want to open i3. How can I change the initial terminal from xterm to termite to match my other setting?

1 Answer 1

1

When you run xinit i3 you will simply add i3 to the default X11 client of xterm, i.e. you will start xterm i3. To show you want to replace the default client completely you need to use the full path to your program, e.g.

xinit /usr/bin/i3

See man xinit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .