0

I use iterm2 on my local MacOS and tmux V3.0a on the target (Windows 10 WSL). When I init a connection with "tmux -CC" I can see something that looks like control traffic. I'd expect that this traffic should be be processed by iterm2 instead of being printed. Also I get no prompt:

ash@mother:/mnt/c/Users/ash$ tmux -CC
1000p%begin 1592235397 281 0
%end 1592235397 281 0
%window-add @2
%sessions-changed
%session-changed $2 2
%window-renamed @2 tmux
%output %2 To run a command as administrator (user "root"), use "sudo <command>".\015\012See "man sudo_root" for details.\015\012\015\012
%output %2 ash@mother:/mnt/c/Users/ash$
%window-renamed @2 bash
%exit

Setup: MacOS Catalina -> SSH -> Windoze 10 -> WSL1 (bash) -> tmux V3.0a

Any ideas why iterm2 does type the control traffic instead of executing it ?

iterm2 Options tried: OFF/ON: Automatic bury the tmux client session after connecting ON: Use tmux profile ON: Status bar shows tmux status bar content

Thanks a lot.

0

Looks like it is trimming off the \033P at the start of the leading DCS sequence (\033P1000p) which iTerm2 uses to detect control mode has been entered. I think you will need to report this to the terminal developers.

| improve this answer | |
  • Ok, thanks for giving a hint. I'll report and leave this thread open until I get response. – Roelof Jun 16 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.