2

I have had this problem since I downloaded Debian 10 KDE Plasma. Any time I run a program I get warning errors about the language settings. I have ran all of the commands to set the language settings such as:

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
sudo locale-gen en_US.UTF-8
dpkg-reconfigure locales
sudo dpkg-reconfigure locales

but every time I re-log in or restart my computer the language settings are gone and I get the same errors/warnings in the programs. Some programs won't run without the settings. A concrete example is when I run R this warning shows:

During startup - Warning messages:
1: Setting LC_CTYPE failed, using "C" 
2: Setting LC_COLLATE failed, using "C" 
3: Setting LC_TIME failed, using "C" 
4: Setting LC_MESSAGES failed, using "C" 
5: Setting LC_MONETARY failed, using "C" 
6: Setting LC_PAPER failed, using "C" 
7: Setting LC_MEASUREMENT failed, using "C" 

Any help on making the settings stay and why this is even happening?

4
  • Open Konsole and put the three export lines into ~/.bashrc . KDE > Systemsettings >language packs offers additional lang packs to install. – Michael D. Jun 14 '20 at 12:38
  • I use zsh -- should I then put it there? – mikanim Jun 14 '20 at 12:49
  • Then put it into the ~/.zshrc file. I wildly guess your trouble may come from using zsh not bash which is default for debian. – Michael D. Jun 14 '20 at 12:53
  • Yep I wildly guess that too – mikanim Jun 14 '20 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.