1

I am using Ubuntu 19.10 and have paired K400+ keyboard with the help of Solaar (ver.1.0.1). I am unable to use the trackpad that comes with the keyboard.

xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech M720 Triathlon                   id=14   [slave  pointer  (2)]
⎜   ↳ Logitech K400 Plus                        id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                        id=15   [slave  keyboard (3)]
    ↳ Logitech M720 Triathlon                   id=17   [slave  keyboard (3)]
    ↳ Logitech K400 Plus                        id=16   [slave  keyboard (3)]
    ↳ 50:A0:09:42:43:BD                         id=10   [slave  keyboard (3)]


xinput --list-props 13
Device 'Logitech K400 Plus':
    Device Enabled (163):   1
    Coordinate Transformation Matrix (165): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Natural Scrolling Enabled (298):   1
    libinput Natural Scrolling Enabled Default (299):   0
    libinput Send Events Modes Available (283): 1, 0
    libinput Send Events Mode Enabled (284):    0, 0
    libinput Send Events Mode Enabled Default (285):    0, 0
    Device Node (286):  "/dev/input/event11"
    Device Product ID (287):    1133, 16461
    libinput Drag Lock Buttons (300):   <no items>
    libinput Horizontal Scroll Enabled (301):   1


synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?

Couldn't figure out what the problem is. Any help would be appreciated.

4
  • maybe the keyboard is defective – jsotola Jun 13 '20 at 11:17
  • works well in windows – neelabalan Jun 13 '20 at 16:29
  • 2
    I don't know what I did. After my second restart the touchpad started working. PROBLEM SOLVED – neelabalan Jun 14 '20 at 3:37
  • Same problem, restart fixed it. Thanks! – Louis Garczynski Apr 20 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.