2

Normally when I have my text editor open in terminal, I use the key combination CTRL+K+V to move to the end of the file

CTRL+K+V does not work when I am in the "main cssh input field", (ie when i am typing in multiple terminals). But if I select one of the open terminals directly, then CTRL+K+V works.

So I assume, when I use it in the main input field, it gets "eaten".

Ideally, I would like cssh to pass all key combination to the terminals. I don't need cssh to use its own key shortcuts.

Is there somewhere where I can configure / disable key shortcuts used by cssh, so that all are passed to terminals ?

Another problem is, when I press F10, it is not passed to the terminals, but opens the menu of cssh. This is pure evil. The cssh window already has menu, where I can click with mouse and select items. Who needs to sacrifice F10, for such stupid thing?

Is it possible to disable all keys in cssh, so that all are passed to the terminals ?

  • Generally speaking, terminals don't do anything interesting with key combinations like that (control+K or control+V, yes, but not all three at the same time). – Thomas Dickey Jun 13 at 8:24
  • Do you mean Ctl-k followed by v? – Barmar Jun 17 at 18:17
  • @Barmar - yes, Ctl-k followed by v – 400 the Cat Jun 18 at 8:26
1
+100

If I unserstood it correctly you want to disable all shorctus for the cssh. This could be done by disabling it in the configuration file.

In your /etc/csshrc & $HOME/.csshrc you need to configure it to:

   use_hotkeys = no
       Setting to anything other than "yes" will disable all hotkeys.

The source of the information were the FreeBSD man pages for cssh

Edit - adding more options

You can try to leave these options empty - don't assign it any default key combination:

   key_addhost = Control-plus
       Default key sequence to open AddHost menu.  See below notes on
       shortcuts.

   key_clientname = Alt-n
       Default key sequence to send cssh client names to client.  See
       below notes on shortcuts.

   key_paste = Control-v
       Default key sequence to paste text into the console window.
       See below notes on shortcuts.

   key_quit = Control-q
       Default key sequence to quit the program (will terminate all
       open windows).  See below notes on shortcuts.

   key_retilehosts = Alt-r
       Default key sequence to retile host windows.  See below notes
       on shortcuts.

   mouse_paste = Button-2 (middle mouse button)
       Default key sequence to paste text into the console window us-
       ing the mouse.  See below notes on shortcuts.

Edit - for future readers The issue appeared to be in the GUI env itself - which was OpenBox. You need to watch out if the settings of the environment do not colide with the cssh ones.

| improve this answer | |
  • Thanks. I changed to use_hotkeys=no, but I see no effect. The problem is still same. – 400 the Cat Jun 19 at 7:31
  • as an example: I launch several terminals with cssh, connecting to remote servers. I start mc and then exit with F10. The F10 worked, in that it exited mc, but after that, the cssh menu is activated, and if I press enter, it does not appear in the terminals. instead it opens the file menu in the cssh menu. – 400 the Cat Jun 19 at 7:35
  • @400theCat are you sure your settings does not get overwritten by the global settings? – tukan Jun 19 at 7:35
  • I don't see any global settings. besides, user settings should always take precedence, if it exists. can use_hotkeys be provided as commandline parameter? I can try that, to be sure. – 400 the Cat Jun 19 at 7:36
  • @400theCat you are right, they should, but we know software, it is full of bugs :). I'll update the answer with more options that could influence it. – tukan Jun 19 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.