0

I’ve installed black arch “from live iso” and it was installed successfully But after reboot it stuck in black screen

starting version 245.5-2-arch
ERROR: device ‘uuid=xxxxxxxxxx‘ not found skipping fsck. 
mount: /new_root: can’t find UUID=xxxxxxx. 
You are now being dropped into an emergency shell. 
sh: can’t access tty; job control turned off[rootfs ]#

By the way I think this picture may help to fix this appears while installing

How can I fix this error ?

0

check if your /etc/fstab has all the partitions that you created, with the corresponding mount points and UUID's.

to get UUID of a drive you can blkid (drive) example blkid /dev/sda1

to list all the partitions you can do lsblk

| improve this answer | |
  • Unlikely to help, since /etc/fstab is stored on root (/). Here the instructions for opening the box are inside the box... The instruction of where to find root (/) must be stored elsewhere in the either the grub menu entry or the initramfs. – Philip Couling Jun 13 at 5:05
  • i guess, you can boot into live usb and arch-chroot /mnt and then edit the file? maybe? – apoorv569 Jun 13 at 5:09
  • you missed my point. The boot sequence doesn't use /etc/fstab to find /. It can't, because /etc/fstab is on /. So the boot sequence must have this one piece of information stored elsewhere. – Philip Couling Jun 13 at 5:11
  • im sorry, im no expert. :/ – apoorv569 Jun 13 at 5:14
  • you can search online for what you just told me. like where does bootsequence stores UUID or something like that. – apoorv569 Jun 13 at 5:21
0

The install script didn't correctly setup which drive to mount as root (/). Maybe something is very broken with your installation maybe it is this one thing. If it's just this, then you can try to fix it manually...

Most partitions are configured inside /etc/fstab but the root partition's information is copied elsewhere. That's because /etc/fstab is stored on root and so this file can't be read until root's been mounted.

Most Linux distributions let you change the root partition during boot by setting the ROOT=... kernel parameter:

  1. Boot your broken system to the point it drops into the emergency shell.

  2. Inside the emergency shell, use the commands lsblk and blkid to list partitions. Work out which one is your root partition. If you followed the installation guide this should be /dev/sda3.

  3. Reboot and when you get to the grub menu, move up / down to "Black Archlinux" and press e. This will let you edit the boot entry.

  4. Carefully look through to find the line starting linux. It's usually a very long line an may have been wrapped (continued to the next line). Check this line to see if there is already an option starting root=. If there is then edit it to the partition you found in step 1. If not then add the option.

  5. Boot your system by pressing ctrlx.


Fixing your system once it's booted

  1. Edit /etc/fstab to correct the entry for / if it's wrong. Even if you didn't use the "UUID" in the steps above, this time you should do so. You can again use blkid and lsblk to find the partition.

  2. Make sure your grub boot entries are up to date by running:

    sudo update-grub
    
  3. Make sure your initramfs is up to date by running:

    sudo update-initramfs -uk all
    

Hopefully this should leave you with a fully bootable system.

| improve this answer | |
  • Thank you for help. label not found. blkid did not get any result, also when I try to mount boot and root using : mount /dev/sda1 “boot” , mount / dev/sda3 “root” it can’t find in /etc/fstab. vi /etc/fstab nothing on it – Dr.Eissa Jun 13 at 13:09
  • [ blackarch / ]# cat /etc/fstab # # /etc/fstab: static file system information # # <file system> <dir> <type> <options> <dump> <pass> # /dev/sda3 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /dev/sda3 / ext4 rw,noatime 0 1 # /dev/sda1 UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx /dev/sda1 /boot ext4 rw,noatime 0 2 # /dev/sda2 UUID=xxxxxxxxxxxxxxxxxxxxxxxx /dev/sda2 none swap defaults 0 0 – Dr.Eissa Jun 14 at 11:47
  • Root is /. Just above the /boot line. blkid needs to be run as root user (eg: sudo blkid). If fstab is empty the you need to populate it. – Philip Couling Jun 14 at 12:49
  • @Dr.Eissa It's a little confusing because the error is for /new_root. That's a quirk of the way linux boots up. / can start life as /new_root earlier on in the boot sequence. – Philip Couling Jun 14 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.