I am running a kali 2020.2 release vm with 5.4.0-kali3-amd64 kernel version. I'm trying to install wine32 package so I can run exe applications. Just stating, I have architecture i386 installed. Here is the command I have been trying to use to install the package. (running as root user)

dpkg --add-architecture i386 && apt-get update && apt-get install wine32

Here is my error.

Hit:1 https://packages.microsoft.com/repos/microsoft-debian-stretch-prod stretch InRelease
Hit:2 http://kali.download/kali kali-rolling InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-9-dev (< 9.3.0-5~) but 9.2.1-25 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I'm no expert at linux or package management but from this error message, I get the impression that I should be downgrading libgcc-9-dev to 9.2.1-25. However doing a quick apt-cache policy libgcc-9-dev returns the following info.

  Installed: 9.2.1-25
  Candidate: 9.3.0-13
  Version table:
     9.3.0-13 500
        500 http://http.kali.org/kali kali-rolling/main amd64 Packages
 *** 9.2.1-25 100
        100 /var/lib/dpkg/status

So, I'm not quite sure what my next move should be here. Can anyone shed some light on this for me? Seems like I'm dealing with some packages here that I shouldn't be treating too lightly. I tried running "dpkg --configure -a" as well to find some held back packages but received no output. Not sure what to do next.

Thanks for any help and for taking the time to read my question.

2 Answers 2


To solve this question, you need to add a package gcc-9-base:i386 use

apt install gcc-9-base:i386

and then you can install

apt install wine


You need to upgrade the already-installed packages:

dpkg --add-architecture i386 &&
apt update &&
apt upgrade &&
apt install wine32

This ensures that the requirements of the new packages you install (wine32’s dependencies) can be satisfied.

  • I appreciate the reply but still no dice. I got a nice kernel upgrade from that and am now on the latest version of kali but the error still persists. I see 150 left back packages as well. Any other ideas? Jun 11, 2020 at 15:58
  • Yes, you need to fix the held-back packages. That might involve apt full-upgrade. Jun 11, 2020 at 16:00
  • That produced the same error. Same with trying to run dist-upgrade as well. I also installed aptitude to see what it would do but it wanted to delete a bunch of "security tool" packages that came with kali. I'm not sure why "dpkg --configure -a" isn't showing any packges but I take it that removing those reported 150 held back packages is what I need to do. I forgot which command allowed me to recieve a list of those packages earlier as well. Sorry for being a bother but any other next steps I should take? I've already created a backup of my vm incase anything goes south too Jun 11, 2020 at 16:39
  • It could be something to do with whatever you’re installing from the Microsoft repository; Stretch is rather old compared to current Kali. Perhaps you could temporarily uninstall those packages, and try again... Jun 11, 2020 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .