0

I'm trying to boot SystemRescueCD via PXE (which is working fine) but it somehow does not run my autorun script. Any idea why? This is what I use as pxelinux.cfg/default:

DEFAULT sysresccd
LABEL sysresccd
  LINUX sysresccd/boot/i686/vmlinuz
  INITRD sysresccd/boot/intel_ucode.img,sysresccd/boot/amd_ucode.img,sysresccd/boot/i686/sysresccd.img
  APPEND archisobasedir=sysresccd ip=dhcp archiso_http_srv=http://192.168.0.1:8181/ checksum docache ar_source=http://192.168.0.1:8181/ autoruns=no ar_nodel ar_wait
  SYSAPPEND 3

There is a http server running at 192.168.0.1:8181 serving up the airoot.sfs as well as a shell script named autorun.

5
  • Complete guess - maybe needs to be autorun.inf? Why have autoruns=no in the command line? – icarus Jun 10 '20 at 22:21
  • From the docs (system-rescue-cd.org/manual/Run_your_own_scripts_with_autorun): "autoruns=[0-9]: comma separated list of the autorun scripts that have to be run. For instance if you use autoruns=0,2,7 then the following autorun scripts will be executed: autorun0, autorun2, autorun7. Use autoruns=no to disable all the autorun scripts with a number." .... "if a shell script named autorun is found, it is run" - so this is just the configuration for a single auto run – Dr. Oliver Friedmann Jun 10 '20 at 22:23
  • Do you have an access log for your http server? Does it show an attempt to get the autorun file? – icarus Jun 10 '20 at 22:33
  • no attempt unfortunately – Dr. Oliver Friedmann Jun 10 '20 at 23:25
  • Downgrading to SystemRescueCD 6.0.3 makes it work. – Dr. Oliver Friedmann Jun 11 '20 at 23:12
0

Seems to be an issue with the newer versions of SystemRescueCD - downgrading to 6.0.3 makes it work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.