0

I followed a few different guides to getting xrdp installed and working on my RHEL machine, but upon logging in with a valid account, the remote session immediately disconnects.

I think I've tracked the issue down to my ~/.xsessions-errors log where this is written:

/usr/bin/xterm: Xt error: Can't open display: %s
Warning: This program is an suid-root program or is being run by the root user.
The full text of the error or warning message cannot be safely formatted
in this environment. You may get a more descriptive message by running the
program as a non-root user or by removing the suid bit on the executable.
/usr/bin/xterm: Xt error: Can't open display: %s
Error: Can't open display: :10.0
Error: cannot open display: :10.0

What are these display errors I'm getting? What can I do to fix them?

There is a question very similar to mine, although our issue seems to be different.

2
  • Are you logged in as root? – jsbillings Jun 10 '20 at 21:09
  • @jsbillings for what? When I log into the RDP page? I believe I tried both but received a different error when I tried doing it with a non-Root user, a nondescript VNC error – Laif Jun 10 '20 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.