0

I am on Three Mobile UK which only issue a dynamic IP and apparently blocked all http ports including 80 so I got a domain stephenogidan.ddns.net from No-IP to fix this issue. So far, I haven't been able to pull it off! This is what I have done so far:

  1. Set up DDNS on my Huawei B535 Router which updates my IP with No-IP. As at the time of writing this, these are the details:

    My Public IP Address: 188.28.69.7
    No-IP Address: 188.28.69.7:8080 (With Port 80 Redirect)
    Dns Lookup IP Address: 34.199.8.144
    
  2. Set up Virtual Server for port forwarding on the same router with the following details:

    Name: Ubuntu
    WAN Port: 80-80
    LAN IP Address: 192.168.8.133
    LAN Port: 80-80
    Protocol: TCP/UDP
    
  3. Set up a host file pointing to a folder with test index.html. The site has been enabled.

    /etc/apache2/sites-available/stephenogidan.conf
    
    <VirtualHost *:80>
        ServerName stephenogidan.ddns.net
        DocumentRoot /var/www/stephenogidan
    </VirtualHost>
    
  4. And finally, this is my /etc/hosts file:

    127.0.0.1 localhost
    127.0.1.1 ubuntu_server
    127.0.0.1 stephenogidan.ddns.net
    

When I visit stephenogidan.ddns.net, below is the response:

This site can't be reached. www.stephenogidan.ddns.net's server IP address could not be found. DNS_PROBE_FINISHED_NXDOMAIN

0
0

There are several issues:

  1. http://xxxxogidan.ddns.net/ forwards to port 8080, but should forward to port 80, there is something wrong in your ddns setup (maybe this No-IP Address: xxx.xxx.xxx.xxx:8080).
  2. http://www.xxxxogidan.ddns.net/ is not the same as http://xxxxogidan.ddns.net/, only the latter one will work (when (1) is fixed).
  3. Your site is listed in available-sites, you have to enable it, e.g. using a2ensite <site>
3
  • First, I will try and see if I can change No-IP's port to 80 because my router won't let me forward to port 80. Second, I will adjust my host file to www.stephenogidan.ddns.net. However, the site is enabled already. I will update you after I make the adjustments. Jun 9 '20 at 12:58
  • your router forwards port 80 ... no, www won't work from ddns site. leave out www
    – pLumo
    Jun 9 '20 at 13:09
  • I have done the adjustments but charges nothing. However, the site is working if I make /etc/hosts entries on the server and on a client (eg laptop). Also if I type 192.168.8.133 on all devices on my network it shows the website. There is a detail I am missing and for the life of me I can't figure it out! Jun 9 '20 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.