I have installed fedora 17 on the old desktop computer and put it to DMZ of my NAT network - i.e. whole computer is accessible via public ip address to the internet and could be called "server".

I've allowed SSH connections on firewall - everything works perfect, but there is one huge problem.

Both me and my friend abroad have Windows 7, so we are using putty + xming to forward windows. My computer (on the same LAN as "server") works without any problem (setting putty like this http://www.geo.mtu.edu/geoschem/docs/images/putty_4.jpg).

Friend, however, he can't open any window (xming is running and putty is configured same as in my computer). He can login using putty, I can see him in who output, he can run console programs (e.g. nano), but he cannot start any GUI program. We tried firefox, firefox &, gedit and gedit &. But after issuing the command, nothing happened - just new command prompt and no process created at all... without any error message...

I've also tried it using his account (from my computer) and everything worked...

any ideas, what could cause the problem? is it possible, that some firewall could allow SSH traffic but block X11 forwarding?

  • 1) unless you've a very wide pipe to your friend abroad, I expect firefox will be quite the dog over remote-x. test with gedit or something even lighter (simple xterm is best). 2) If there's no error, run a ps command after executing xterm and see if the process is listed. If it is then....it's running, but the remote computer's xming isn't displaying it. Also, make sure $DISPLAY is correct. PS: just noticed how old this question was.
    – SuperMagic
    Commented Feb 20, 2013 at 20:35

2 Answers 2


This is a little bit of a complicated thing to try doing if you're not that familiar with ssh, X11, and firewalling in general. Have a look at these howtos for guidance on how to do this:

In general you're going to need to configure your SSH client so that all the X traffic being generated from the remote system should tunnel back through the SSH connection. If this isn't setup correctly then the X traffic will try and go over port 6000 from the remote system back to you.

I suggest NOT going the route of allowing the 6000 port traffic, given this would allow others to sniff your network traffic and see X data going back and forth. X in general is good for LAN but not WAN connections.

Also you might want to check out teamviewer. It's free and would allow you to share desktops back and forth. It runs under Linux & Windows and get's around the firewall issues that usually plague people who don't have a fairly deep knowledge of these things.

  • wireshark on LAN windows computer doesn't show any traffic on port 6000, everything is going through tcp 22... anyway, I know it is not the most suitable solution - I just need to share my internet connection to the friend... after squid proxy has failed (it works from some networks, but not for him, because its traffic to the "server" is not encrypted) I decided SSH X11 forwarding is the simpliest way for me to configure... well, looks like I was wrong and have to study how to configure openvpn :-)
    – Tomas
    Commented Dec 22, 2012 at 12:15
  • I would give teamviewer a try, I use it regularly in a variety of network topologies and it has always worked without issue. teamviewer.com/en/index.aspx
    – slm
    Commented Dec 22, 2012 at 14:20

Try setting X11UseLocalhost no on the server-side sshd_config. I had a similar issue and that solved my problem!

  • You can also set this in ~/.ssh Commented Sep 19, 2017 at 2:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .