1

I have been working on installing dual boot on my Acer Nitro AN515-51 laptop (with pre-installed Windows 10) for several days now, and am hoping some of you Linux gurus can help a very frustrated (but determined) newbie out.

TLDR: I reinstalled Debian on a dual boot Windows 10 computer, but both the original Debian install and the new Debian freezes when I try to reboot the computer.

System specs

Graphics: Nvidia GeForce GTX 1050 ( 4GB VRAM); Intel UHD Graphics 630.
RAM: 8GB SDRAM (DDR4)
HD: 256MB Solid State Drive

lscpu | grep -i model reports this:

Model:               158
Model name:          Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz

There are 5 partitions on the disk:

/dev/nvme0n1p1 100MB EFI System Partition (FAT32)
/dev/nvme0n1p2 16MB Microsoft reserved
/dev/nvme0n1p3 134.6GB Microsoft basic data (NTFS)
/dev/nvme0n1p4 1GB Windows recovery environment (NTFS, hidden)
/dev/nvme0n1p5 102.8GB Linux filesystem (ext4)

My Windows 10 has always been UEFI enabled and Secure Boot enabled and the disk is GPT. I disabled 'Fast Startup' just in case it would cause issues.

DESCRIPTION of issue: This computer previously had Debian 10.1 installed (by a friend, not by me), but I decided to reinstall it due to a rebooting issue where it would freeze upon attempting to restart through the GUI. When I tried to fix this issue, I broke Debian and was no longer able to login. I actually successfully reinstalled Debian, only to get this same rebooting issue (freezing when I try to restart through GUI).

Here are the steps I took to install Debian 10: I first used Rufus 3.10 to create a bootable USB thumb drive. I tried several different .iso's. These were all created with GPT partition scheme, UEFI, FAT32. The first one I tried was the debian-10.4.0-amd64-netinst. This turned out to be missing some firmware that my hardware required to operate (which had to do with my Qualcomm Atheros QCA6174A wireless network adapter) which I added. I got all the way to the installing GRUB bootloader step. This is when I got an error saying that the GRUB bootloader did not install properly. The exact error I get is:

`Unable to install GRUB in dummy. Executing 'grub-install dummy' failed. This is a fatal error.'

I try to install anyway. It says I will need to boot manually with the /vmlinuz kernel on partition /dev/nvme0n1p5 and root=/dev/nvme0n1p5 with quiet passed as a kernel argument.

I then tried installing from a Debian 10.4 Live .iso with Cinnamon DE. After Debian Live booted up, I used Calamares to install Debian. I made sure to mount the EFI System Partition (ESP) to /boot/efi and that it is marked both as efi and boot and that the bootable flag is on. I did not format it. I set partition 5 as ext4 and mount root as /. I did format this partition. Then I proceeded with the install. I again get the same error that I got previously about not being able to install GRUB bootloader. I also get the error:

Installation failed
Command `grub-install --target=x86_64-efi --efi-directory=/boot/efu --bootloader-id=Debian -force` returned non-zero exit status 1. 
Installing for x86_64-efi platform. 
grub-install: warning: Cannot set EFI variable Boot0004.
grub-install: warning: efivarfs_set_variable: writing to fd 8 failed: No space left on device. 
grub-install: warning: _efi_set_variable)mode: ops->set_variable() failed: No space left on device. 
grub-install: error: failed to register the EFI boot entry: No space left on device.

I try this same process with Debian Live Mate, but same issue with grub bootloader installation. Debian didn't even show up on the boot menu options, only Windows Boot Loader.

Third time, I use Debian Live non-free CD .iso with Cinnamon. This comes with all the missing firmware so I can connect to my wireless network. I then login to the terminal to clear the dump files via sudo rm /sys/firmware/efi/efivars/dump-* And finally, Debian 10 is installed successfully. However, when I try to restart, again computer instantly freezes. I have manually reboot, and as Debian is starting up, I get messages such as 'problems loading UEFI' but it's so quick that I can't really read what it says.

I just want to restart my laptop properly through the GUI!

Does anyone have any suggestions as to what might be the problem here?

Thanks in advance :)

EDIT 1 I upgraded my Linux kernel by following the instructions in this Youtube video: https://www.youtube.com/watch?v=_9UqAcVMro8 But the rebooting issue is still not resolved. Back to the drawing board...

EDIT 2 After running sudo dmesg -T, I don't see any error messages about UEFI. I do see a lot of messages about nouveau. One of them says WARNING: CPU: 3 PID: 151 at drivers/gpu/drm/nouveau/nvkm/subdev/mmu/vmmgf1000.c:07 gf100 vmm flush +0x14e/0x190 [nouveau]

sudo journalctl does show the error messages that I always see when I boot up Debian, right before the login screen.

Problem loading UEFI:db X.509 certificate (-65)` 

Also see these errors:

Lockdown: Hibernation is restricted; see https://wiki.debian.org/SecureBoot
wmi_bus wmi_bus-PNP0C14:01: WQ data block query control method not found
r8169 0000:03:00.1: can't disable ASPM; OS doesn't have ASPM control
ACPI Warning: \_SB.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20180810/nsarguments-66)
ACPI Warning: \SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20180810/nsarguments-66)
[Firmware Bug]: ACPI(PEGP) defines _DOD but not DOS
  • As you mention that you're having trouble reading the messages from boot, try running dmesg -T and you might be able to read them. You can also count on sudo journalctl for general logging. Add the error messages you find to your post as that will help troubleshooting immensely. – Zip Jun 8 at 22:15
0

I am posting my solution in case someone else experiences the same issues as me.

I should also mention that on top of the rebooting issue, my computer started to freeze whenever I opened Firefox. This was after I did a sudo apt-get update and sudo apt-get upgrade

I fixed both of these issues by simply disabling nouveau kernel drivers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.