I am trying to get a very simple tftp server working. I followed the guides at several websites, including how-to-setup-tftp-on-ubuntu and installing-and-testing-tftpd-in-ubuntudebian, but I haven't been able to get a tftp server working.

The xinetd service is running (I know this because I do a ps -A | grep xinetd and see it), but I don't see tftp in netstat -na | grep LIST | grep 69. In other words, xinetd is running but I don't see the tftp server. I tried connecting to the server from my Windows tftp client but it failed, so I know for sure it's not running.

My /etc/xinetd.d/tftp config file looks like this:

service tftp
    protocol = udp
    port = 69
    socket_type = dgram
    wait = yes
    user = nobody
    server = /usr/sbin/in.tftpd
    server_args = -s /tftpboot 
    disable = no

The /tftpboot is owned by nobody:nogroup, and mode to 777.

I thought maybe it was a firewall issue but ufw says it is inactive. In case it matters, Ubuntu is running inside a VirtualBox VM with the ethernet adapter bridged (not NAT) to my home network.

I also tried directly running /usr/sbin/in.tftpd and used the --foreground option, but it closes right away.

  • FYI, It's probably closing quickly b/c in.tftpd is already using the port (69). Only one process can use the port at a time. – slm Dec 22 '12 at 5:41
  • 1
    Can you connect to the tftp server locally? Try this cmd. on the tftp server: tftp GET someimage – slm Dec 22 '12 at 6:08
  • What is the output of using strace with it running in the foreground? – Chris Down Dec 22 '12 at 9:00
  • Once restart xinetd service and check tail -20f /var/log/syslog. if possible post on question – Rahul Patil Dec 22 '12 at 9:07
  • 1
    I was able to connect to it locally! The netstat -na | grep LIST | grep 69 is wrong because there is no LISTENING text in the netstat output for the tftp server. I ran sudo netstat -pa | grep xinet and saw the server on port 69. As for why Windows couldn't see it, I turned off the Windows firewall and it worked, so the damned Windows firewall was secretly blocking it! – datadamnation Dec 22 '12 at 16:15

Browse other questions tagged or ask your own question.