0

So unlike a lot of the other posts that I've seen I'm running into a problem with my Debian dual boot installation after I tried to upgrade.

Background: dual boot has been working for years with grub boot loader being the default boot loader. Yesterday I attempted an apt-get upgrade and apt-get full-upgrade in an attempt to upgrade my installation from Debian 9 (Stretch) to Debian 10 (Buster). Finally I ran apt-get --purge autoremove.

I rebooted the system and the partition doesn't appear as bootable anymore in the BIOS.

What I've Tried:: I figured it was an issue with the upgrade breaking something in GRUB so I installed a Debian 9 ISO to a USB and attempted to install GRUB through the rescue mode. This always fails. Note: I used the graphical interface.

I Tried to use the rEFInd Boot Manager, but the only option that gave was "default" and it just rebooted my machine without any noticeable difference.

I confirmed that the partition I was trying to re-install GRUB on was the debian partition because I was able to open a shell into /root on that partition.

Punchline: at this point I'm at a loss for how to get this partition bootable again. Worst case I can sync the whole partition externally and fresh reinstall Debian but I'd prefer not to do that.

Also let me know what information is most useful for y'all to help me out here.

SOLVED: Did what Jonah mentioned below and solved boot variable errors with the link I shared in subsequent comments.

6
  • re-boot in rescue mode run shell on that partition again and reinstall grub sudo grub-install /dev/sdX; sudo update-grub sdX should be your hard drive not the usb sda or sdb according to you , run lsblk to see – Yunus Jun 7 '20 at 16:46
  • So I'm not sure exactly which device to run grub-install on. The partition I booted the shell into was /dev/nvme0n1p6 and that's what shows up as room mountpoint when i run lsblk there's one called nvme0n1p1 who's mountpoint is /boot/efi – user2419509 Jun 7 '20 at 17:58
  • I mean "root* mountpoint" up there and nvme0n1 is the disk and the rest are the partitions – user2419509 Jun 7 '20 at 18:04
  • then sudo grub-install /dev/nvme0n1 – Yunus Jun 7 '20 at 18:12
  • okay so I first got a boot variables error and followed these instructions: unix.stackexchange.com/questions/379774/… but regardless, I still get Could not prepare Boot variable: No space left on device – user2419509 Jun 7 '20 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.