0

I've got XRDP installed on two of my CentOS7 machines, on one of them , XRDP works fine and allows connections straight away from when the machine is booted up. However, on the other, I have to boot up, then enter the commands:

systemctl stop xrdp
systemctl start xrdp
systemctl enable xrdp

Then it allows connections for about an hour, then I have to use those commands again....

Anyone have any ideas?

7
  • The systemctl enable xrdp should set the xrdp service to start up automatically at boot time. If that is getting undone, it suggests the system may be under some sort of automated management (think Ansible, SaltStack, Puppet or something similar) that is enforcing some settings at intervals of about an hour, including the fact that xrdp should be shut down. Talk to your fellow system administrators.
    – telcoM
    Jun 7 '20 at 17:26
  • @telcoM I am my only administrator :D
    – ekv_56
    Jun 7 '20 at 17:30
  • Alternatively, if the system is exposed to traffic from the internet, XRDP might be crashing because various automated malware on the internet are running portscans and Windows RDP exploits against it. In that case, you really should set your firewall to block traffic to XRDP's port from any untrusted networks ASAP.
    – telcoM
    Jun 7 '20 at 18:14
  • @telcoM How can I configure my firewall to do that?
    – ekv_56
    Jun 8 '20 at 7:19
  • I don't know what firewall you're using, if any. If you are using CentOS 7's default firewalld, you have already had to do something with it to enable access to xrdp from the network. But at the basic level, firewalld only allows enabling/disabling access to services by network interface. If you have just one NIC in use, you'll need the more advanced rich rules to specify that xrdp access should be allowed from your own IP subnet(s) only.
    – telcoM
    Jun 8 '20 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.