0

I am trying to install python3-pygrib on CentOS 7. First I needed to install eccodes, libpng and pyproj. Before those libraries, I need to install glibc231. I ran into circular dependencies trying to do a yum local install with the rpm's:

Error: Package: glibc231-common-2.31-3.gf.el7.x86_64 (/glibc231-common-2.31-3.gf.el7.x86_64)

Requires: glibc231 = 2.31-3.gf.el7

Error: Package: glibc231-2.31-3.gf.el7.x86_64 (/glibc231-2.31-3.gf.el7.x86_64)

Requires: glibc-common = 2.31-3.gf.el7

I tried this:

 rpm -i glibc231-2.31-3.gf.el7.x86_64.rpm glibc231-common-2.31-3.gf.el7.x86_64.rpm glibc231-langpack-to-2.31-3.gf.el7.x86_64.rpm

And got this:

warning: glibc231-2.31-3.gf.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID da8b7718: NOKEY
error: Failed dependencies:
    glibc-common = 2.31-3.gf.el7 is needed by glibc231-2.31-3.gf.el7.x86_64

I also tried --nodeps --force, and it said --force is not an option. Is there another workaround I can t?ry

6
  • "--nodeps" failed? That would be the first thing I would try. What was the error message? Are there are custom rpms on this system? Did you verify the checksums of the rpms? – llywrch Jun 5 '20 at 23:33
  • --nodeps alone didn't work, the --force caused an error. – Jeanne Lane Jun 6 '20 at 4:55
  • To repeat myself, what was the exact error message? Are there are custom rpms on this system? Did you verify the checksums of the rpms you tried to install? – llywrch Jun 7 '20 at 19:27
  • Loaded plugins: fastestmirror, langpacks Usage: yum [options] COMMAND List of Commands: check Check for problems in the rpmdb check-update Check for available package updates updateinfo Acts on repository update information upgrade Update packages taking obsoletes into account version Display a version for the machine and/or available repos. Command line error: no such option: --force – Jeanne Lane Jun 8 '20 at 17:14
  • I am new to Linux, so it looks like the procedure y=to verify the checksum of rpms is to run the command rpm -K myrpm.rpm. For each one, it's missing the RSA/SHA signature, but MD5 was okay – Jeanne Lane Jun 8 '20 at 17:15
1

If you've downloaded the packages, just use rpm, not yum. Like this:

rpm --nodeps glibc231-2.31-3.gf.el7.x86_64.rpm

This is what I thought you were doing in the first place. (Yum is useful if you are installing packages & don't want to fiddle with all of the dependencies. If you need control over the dependencies, fall back to using rpm.)

1
  • It looks like I can't install the version of glibc on CentOS 7, but your advice led to more helpful error messages. – Jeanne Lane Jun 9 '20 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.