0

I know this is a common problem that has likely been addressed here before, but thus far none of the obvious solutions have worked.

I'm trying to install Debian on my laptop (currently running Ubuntu) from a USB flash drive. I have reformated the drive to the FAT32 file system and made sure it has only one partition, I have used Unebootin to create the proper files on my flash drive, installed the ISO image on my root directory and the USB drive, programmed my BIOS chip to boot from the USB (put the HD last in boot order), and disabled secure boot and fast boot; but it just won't boot from from the USB drive. Instead it just boots directly to Ubuntu as if that was the only choice available. I've even tried pressing F2 during the boot sequence and have also tried using both USB ports on my computer, but to no avail.

If I have to, I suppose I can live with Ubuntu, but I've been married to Debbie over a decade now and really don't feel like getting to know a whole new OS - even if she's related. Any hints or suggestions would be much appreciated.

Thanks.

4
  • Do you have a uefi vs legacy boot option in the bios?
    – icarus
    Commented Jun 5, 2020 at 21:41
  • "I have reformated the drive to the FAT32 file system", which: the target installation drive or the USB flash? Commented Jun 5, 2020 at 22:20
  • 1
    "[I have ...] installed the ISO image on my root directory" that's not how you should boot from Debian ISO media. Put the ISO image onto the raw USB stick. Not onto a filesystem. You don't need a boot helper. Just boot the ISO image. Commented Jun 5, 2020 at 22:21
  • 0. Unetbootin is a complicated extracting tool and may have problems with your iso file. 1. Check that the iso file was downloaded correctly (with a checksum test); 2. Use a cloning tool with a final checkpoint, for example Disks alias gnome-disks or mkusb in Ubuntu; 3. It is also possible to copy directly to the block device (of the USB pendrive) but it is risky. Too many people have overwritten their internal drive that way. -- This link may help because cloning works with Debian as well as with Ubuntu.
    – sudodus
    Commented Jun 5, 2020 at 23:26

1 Answer 1

0

I suspect your installation method with UNetbootin is the culprit. The Debian Installation Guide recommends to copy the ISO directly to the device. This is easy and should always work.

The CD or DVD image you choose should be written directly to the USB stick, overwriting its current contents. For example, when using an existing GNU/Linux system, the CD or DVD image file can be written to a USB stick as follows, after having made sure that the stick is unmounted:

cp debian.iso /dev/sdX
sync

...
Important
The image must be written to the whole-disk device and not a partition, e.g. /dev/sdb and not /dev/sdb1. Do not use tools like unetbootin which alter the image.

Please try that.

1
  • Well, I seem to have bricked my USB stick. I could buy a new one and try this again or I could just purchase a USB stick with a Debian ISO already on it; I think I'll opt for the latter. But thanks everyone for your advice.
    – nheeghee
    Commented Jun 10, 2020 at 1:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .