1

I have Debian 10 Buster installed on my Acer Nitro AN515-51 laptop (dual boot with Windows 10). These are the system specs:

Graphics: Nvidia GeForce GTX 1050 ( 4GB VRAM); Intel UHD Graphics 630.
RAM: 8GB SDRAM (DDR4)

lscpu | grep -i model reports this:

Model:               158
Model name:          Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz

uname -a reports this:

Linux rpl-pc 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux

lspci -k | grep -EA3 'VGA|3D|Display' reports this:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
        Subsystem: Acer Incorporated [ALI] HD Graphics 630
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
        Subsystem: Acer Incorporated [ALI] GP107M [GeForce GTX 1050 Ti Mobile]
        Kernel modules: nouveau
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

The Problem: When I type

sudo apt-get upgrade

I get the following output into my terminal (I only copy/pasted the last few lines where the error occurs):

Preparing to unpack .../nvidia-legacy-check_418.113-1_amd64.deb ...
Checking for legacy NVIDIA GPUs appears to hang, try rebooting with 'acpi=off'
added to the kernel boot options in the GRUB configuration.

Then the terminal appears to freeze and I can't Ctrl-C out of it.

The same issue occurs when I try to install a program through the command line (e.g. sudo apt-get install vim)

Why am I getting these errors?

Is this related to the fact that I was never able to get my computer to reboot properly and it freezes every time I go to the Start Menu to Leave and either Reboot or Shutdown? I have to hold down the power button and manually shut down. I have no other issues with Debian 10 Buster so far.

EDIT: I was able to execute sudo apt-get upgrade as well as install vim successfully by turning acpi off temporarily through the GRUB menu. It also reboots/shuts down properly through the GUI. However I still can't figure out how to get my computer to reboot the proper way via the GUI without acpi=off. I don't want to turn acpi off permanently because according to this post, it's not recommended to do that if you have a laptop. It does lead me to believe it's an ACPI issue though.

I tried the following methods:

  1. Editing /etc/default/grub as follows:

    GRUB_CMDLINE_LINUX_DEFAULT="splash quiet noefi reboot=pci"
    

    then running:

    sudo update-grub
    
  2. /etc/default/grub:

    GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi=force apm=power_off
    

    and /etc/modules:

    apm power_off=1
    

    then

    sudo update-grub
    
  3. Deleting splash and quiet from the grub file

  4. Disabling nouveau kernel driver as described here: https://askubuntu.com/questions/841876/how-to-disable-nouveau-kernel-driver

However, none of these methods worked. I am booting in UEFI mode. Does anyone have other suggestions I can try?

EDIT 2 After doing a fresh install of Debian Buster, I ran into the same issue. I even updated the Linux kernel. In fact, on top of the rebooting issue, my computer froze whenever I opened Firefox. I ended up fixing these issues by disabling the nouveau kernel drivers. I also installed the proprietary NVIDIA GPU drivers, but as of this update, I have not gotten them to load yet, so disabling the nouveau kernel drivers was enough. Hopefully, this will help someone else out there who experienced the same issues as I did.

4
  • Have you tried to boot with kernel parameter acpi=off before running apt? Instructions here. – Freddy Jun 4 '20 at 20:43
  • @Freddy I'm a bit hesitant to do that because of what I read here: askubuntu.com/questions/858370/is-it-dangerous-to-turn-acpi-off The person who responded to that post doesn't recommend turning acpi off if you're using a laptop. I have a gaming laptop which does get pretty hot when I am playing games. I am concerned that it will cause too much wear and tear. – rplee Jun 4 '20 at 21:05
  • I don't mean permanently, just once via grub menu and e to install nvidia-legacy-check_418.113-1_amd64.deb. Don't know if this works, but may be worth a try. – Freddy Jun 4 '20 at 21:09
  • @Freddy I tried it just now and I was able to run sudo apt-get upgrade and sudo apt -y install vim successfully! Also I was able to reboot my laptop via the Start Menu -> Leave -> Reboot. However, since I had only temporarily turned acpi off, when I tried rebooting again through the Start Menu (while acpi was on), it froze as usual. So I'm still not sure how to reboot the proper way without permanently turning acpi off. – rplee Jun 4 '20 at 21:52
2

Unfortunately this is still too unspecific to give you a definitive answer but here are some things you can try:

  • Check the system log files by running sudo less /var/log/syslog and sudo less /var/log/kern.log. Look for messages related to ACPI or your NVIDIA drivers. Maybe it contains some errors that point you into the right direction? Be sure to search the Web for these errors.

  • The Linux kernel accepts a ton of parameters related to ACPI. Try disabling ACPI partially (e.g. acpi=noirq or pci=noacpi) to figure out which part of ACPI you are having problems with. Maybe power consumption is still acceptable?

  • Many issues related to power management are caused by firmware bugs that are discovered and fixed after vendors started selling their devices. Check the vendor's website to see if BIOS updates are available for your machine.

  • Using the proprietary NVIDIA driver can be quite a hassle. Many Linux users decide to stick to open-source drivers that often offer less performance but better compatibility with the rest of your Linux system. If that's not an option for you, you might want to tap into the experience of others running these drivers. The Debian Wiki provides some information on NVIDIA drivers. Note that it mentions a newer version that is available from the buster backports repository. Maybe that helps?

  • Your laptop seems to be a pretty new model. Try a distribution like Ubuntu or Fedora that comes with a more recent kernel and drivers. Booting a live system from a thumb drive might be sufficient for testing.

6
  • Ah ok. I will try these suggestions. Btw when I run sudo less /var/log/kern.log I see a lot of these messages: CPU1: Core temperature above threshold, cpu clock throttled (total events = 1) and CPU1: Package temperature above threshold, cpu clock throttled (total events = 1) So it looks like my CPU is overheating. I'm not sure if it's a related issue or a separate one? – rplee Jun 6 '20 at 1:02
  • I checked the Acer website for my laptop model and I see that they have released BIOS version 1.22 whereas I have BIOS version 1.13. I don't think I have upgraded my BIOS before, so am a bit nervous doing something like that. I will see if some of the other options work first. – rplee Jun 6 '20 at 1:50
  • Since I'm able to reboot/shut down properly with acpi=off, it leads me to believe that it's a Linux ACPI issue. I also tried acpi=noirq, and it allowed me to reboot/shut down through the GUI instead of manually. However, when I try to login, I can't enter my password. So clearly not an option :( I haven't tried pci=noacpi but I'm guessing it'll have the same issue since it disables both IRQ routing and PCI scanning. I also did sudo less /var/log/syslog and got no messages about NVIDIA drivers. There were lots of messages about ACPI but didn't see any errors. – rplee Jun 6 '20 at 2:30
  • Ok I just tried pci=noacpi and that was even worse than acpi=noirq I was able to reboot through the GUI but this time Linux wouldn't even load. It just freezes before I even get to the login screen. – rplee Jun 6 '20 at 2:41
  • Wow... very strange. I changed my grub config file back to GRUB_CMDLINE_LINUX_DEFAULT="splash quiet" and now, it reboots through the GUI! I'm not sure what I did that fixed this issue, but I will accept your answer because something you suggested must have worked and they are all good suggestions. Thanks! – rplee Jun 6 '20 at 3:15
0

my answer is, probably, not 100% relevant, but it may still give some clue. I had the same problem with Debian 10 and CentOS 7 on 32bit embedded machine (UNO-2372G-E021AE), and the problem was related, most likely, to EHCI/XHCI hand-off (from journalctl). And in my case the solution was to change preferred OS in BIOS from Windows 7 or Windows CE to Windows 8.X or Windows 10. Neither acpi=off or EHCI/XHCI disabling/enabling/Auto options worked for me. This is a specific case, but may be it will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.