2

I'm running Kubuntu 20.04 64-bit with zsh as my shell. I installed wine-platform-runtime and wine-platform-5-staging as snaps. However, zsh doesn't recognize it's installed.

The following 3 commands don't work:

  • wine
  • wine-platform-5-staging
  • wine-platform-runtime

I haven't tried switching to bash and testing the commands.

When I installed Wine from their website previously, it worked just right. I need those packages specifically in order to run some software (League of Legends)

I've had path issues with zsh before — could it be the reason?

Update: which doesn't work for any of them, either, yet they're still installed.

Update 2: answer from the developer of the leagueoflegends snap on the repository of the snap about the path - there are no launchers nor exec commands:

This snap (leagueoflegends) uses wine-platform-5-staging & wine-platform-runtime snaps respectively are basically content snap which does not provides any launchers or exec commands but are mounted in this snap root path to expose there content to be used..

Still, why is my shell still unable to find them (as per update 1)?

I installed leagueoflegends with --devmode`. Could it be somehow with the installation being restricted, per the snap documentation?

Devmode A special mode for snap creators and developers. A devmode snap runs as a strictly confined snap with full access to system resources, and produces debug output to identify unspecified interfaces. Installation requires the --devmode command line argument. Devmode snaps cannot be released to the stable channel, do not appear in search results, and do not automatically refresh.

2
  • It's probably a path issue indeed. I think snap installs programs in nonstandard locations. I guess it adds them to the path in a way that only works with bash. Jun 4, 2020 at 20:52
  • Any idea on how to fix this? I don't know much about wine so I don't know what file I should source in .zshrc. Jun 5, 2020 at 20:55

1 Answer 1

0

I don't run Kubuntu and don't use Snapcraft, but when I install wine-stable through Homebrew, it runs an installer which puts it in /usr/local/bin/, which is already in my path.

Try installing wine again and in the installer's output, take note of where the commands get installed. Then, check if that dir is in your $path, by doing echo ${(F)path} on the command line. (The (F) puts each item on a new line, for easier readability.) If the dir where the wine commands get installed are not in your $path, then you can add it like this (using /usr/local/bin/ as an example value):

typeset -U PATH path
path=( /usr/local/bin/ $path )

(typeset -U ensure you don't get duplicate entries.)

2
  • Did you install it via snap or via your regular package manager? Please do notice my 2nd update. I think it could be because of the snap installation restriction(s). Jun 22, 2020 at 17:49
  • No idea, but good to see that you've got a conversation going with the developer of that snap. Hopefully, he can sort it out for you. Jun 24, 2020 at 8:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .