0

I'm using KDE plasma, and an ethernet adapter to install things on my laptop before getting wifi working.

But I can't seem to get wifi to work at all.

Here's some things I tried:

$ iwconfig

enp0s13f0u3u2  no wireless extensions.

lo        no wireless extensions.

Sorry if my formatting is wrong. Note that enp0s13f0u3u2 is my ethernet connection/adapter (I'm pretty sure).

    $ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: enp0s13f0u3u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 4c:e1:73:42:1c:97 brd ff:ff:ff:ff:ff:ff

For ispci: I only pasted the relevant info

    $ lspci
00:14.3 Network controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW) (rev 30)

I kind of really need wifi on this laptop. Thanks a bunch guys, let me know if there's anything else you need me to provide.

edit: I've installed network manager, wpa_supplicant, netctl, wireless_tools

Also when I try to just use wifi-menu I get invalid interface specification

1
  • What kernel version are you using? I've seen some reports of issue with this network controller: bugs.archlinux.org/task/64703 also found some ubuntu reports. Maybe try a kernel mentioned on the link I provided? Like 5.3.13
    – vfbsilva
    Jun 3, 2020 at 5:07

2 Answers 2

0

Listing network interfaces

Both wired and wireless interface names can be found via ls /sys/class/net or ip link. Note that lo is the loop device and not used in making network connections.

Wireless device names can also be retrieved using iw dev. See also /Wireless#Get the name of the interface.

If your network interface is not listed, make sure your device driver was loaded successfully. See /Ethernet#Device driver or /Wireless#Device driver.

Enabling and disabling network interfaces

Network interfaces can be enabled / disabled using ip link set interface up|down, see ip-link(8).

To check the status of the interface eth0:

$ ip link show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state DOWN mode DEFAULT qlen 1000

The UP in <BROADCAST,MULTICAST,UP,LOWER_UP> is what indicates the interface is up, not the later state DOWN.

0

Have you tried installing linux-firmware and iwlwifi?

sudo pacman -Syu linux-firmware iwlwifi

Then try loading the module:

sudo modprobe iwlwifi

Let me know if it works

EDIT:

edit: I've installed network manager, wpa_supplicant, netctl, wireless_tools Did you installed dialog & dhcpcd?

pacman -Syu dialog dhcpcd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .