0

I just installed Zabbix-5.0 LTS on RHEL-8 OS. After logging in on the Zabbix fronend, I get message that "Zabbix server is not running:the information displayed may not be correct". Kindly help me with server installation.

My Zabbix server port is 10051.

On entering service zabbix start, I get output:

Redirecting to /bin/systemctl start zabbix.service
Failed to start zabbix.service:Unit zabbix.service not found.

and on entering systemctl restart zabbix-server zabbix-agent httpd php-fpm I get:

Job for zabbix-server.service failed because the control process exited with error code.
See "systemctl status zabbix-server.service" and "journalctl -xe" for details.

Output of "journalctl -xe":

RHEL8 platform-python[5746]: SELinux is preventing zabbix_server from using the dac_override capability.

*** Plugin dac_overrride (91.4 confidence) suggests ************************
If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
#auditctl -w /etc/shadow -p w
Try to recreate AVC.Then execute
#ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla

*** Plugin catchall (9.59 confidence) suggests *************************

If you believe that zabbix_server should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
#ausearch -c 'zabbix_server' --raw | audit2allow -M my-zabbixserver
#semodule -X 300 -i my-zabbixserver.pp           

RHEL8 dbus-daemon[779]: [system] Activating service name='org.fedoraproject.Setroubleshootd' requested by ':1.40' (uid=0 pid=748 comm="/usr/sbin/sedispatch " label="sytem_u:system_r:auditd_t:s0") (using servicehelper)

On entering "systemctl status zabbix-server.service", I get output:

zabbix-server.service-Zabbix server: Loaded:....
                                   Active:....
                                   Process: 4959 
ExecStart=/usr/sbin/zabbix_server -c $CONFILE (code=exited,status=1/FAILURE)
RHEL8 systemd[1]:zabbix-server.service:Control process exited,code=exited status=1
RHEL8 systemd[1]:zabbix-server.service:Failed with result 'exit-code'.
RHEL8 systemd[1]:Failed to start Zabbix Server. What do I do now?
  • Done.Can you now help me regarding this? – BABUPINKY Jun 4 '20 at 22:32
  • How was zabbix installed? – Jeff Schaller Jun 4 '20 at 22:42
  • Via packages from here:zabbix.com/download – BABUPINKY Jun 4 '20 at 22:44
  • I suspect that the installation process did not account for SELinux. If you have the steps you took, those might be useful to address the problem. – Jeff Schaller Jun 4 '20 at 22:46
  • Thanks it worked – BABUPINKY Jun 4 '20 at 23:36
-1

Solved. I had to configure SELinux. Just go to "vim /etc/selinux/config" & change SELinux from "enforcing" to "permissive".After that,reboot the system & then Zabbix server will start working.

  • There are surely more-secure ways to solve this problem. – Jeff Schaller Jun 5 '20 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.