14

It seems the common solution to this is to run remove /etc/initramfs-tools/conf.d/resume and run update-initramfs -u.

But it is unclear how you get to that stage.

Can you give a special command to GRUB to ignore the resume for a single boot? Or is there a different trick to get past the blocking?

3
  • 1
    As of 22.04 LTS this no longer blocks boot, but it does pause for something like 30s and then prints "Gave up waiting for suspend/resume device" if you are watching the console.
    – kiko
    Jan 9, 2023 at 19:48
  • Also, am not sure whether the fix is to remove or just to fix that file. Keep in mind that the reason this happens is that the swap device set in that file is not available at boot.
    – kiko
    Jan 9, 2023 at 19:49
  • worked fine for me in my situation askubuntu.com/questions/1470944/…
    – Ashu
    Jun 10, 2023 at 17:24

4 Answers 4

14

Yes, there is "a special command", more specifically a Linux kernel boot option.

A lot of kernel boot options are available for various purposes.

To skip the attempt to resume from a configured suspend/resume disk/partition (usually a swap partition):

Interrupt GRUB by pressing any key, then press E to edit the currently-selected boot entry, find the line starting with the word linux and add noresume as a separate word to the end of that line.

This change will not persist: it will take effect for this one boot only. For a persistent change, use the instructions you mentioned in the question.

1
  • You can also add the noresume to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and run sudo update-grub.
    – qsantos
    Jan 9 at 7:05
11

A better answer than removing it is to fix it.

If you have a dedicated swap partition, use the blkid command to find its UUID.

Then copy this (select, press Ctrl+Shift+C in the terminal window), edit the /etc/initramfs-tools/conf.d/resume file, make sure it has the correct UUID (select the old one, delete it, press Ctrl+Shift+V to paste).

Save it.

Rerun

update-initramfs -u

Reboot.

9
  • It is a good answer to a different question. Here the question is for the situation how to get the machine to boot to actually get to the stage where you can run blkid.
    – Ole Tange
    May 8, 2023 at 13:51
  • They could always run it from a live USB medium. May 12, 2023 at 23:48
  • That would be an answer to the question - but a poor one. telcoM's answer is bang on target.
    – Ole Tange
    May 13, 2023 at 6:06
  • Interesting. I think "here is how to fix this" is a better answer than "here is how to temporarily bypass the problem", even if that is what was asked. May 15, 2023 at 18:16
  • 2
    alternative to noresume: RESUME=none
    – Ben
    Oct 23, 2023 at 8:29
0

Since this is one of the first results when searching "ubuntu 20.04 gave up waiting for suspend/resume" on Google, I should mention that before trying to tinker with initramfsto solve the problem, the first step to solve the "Gave up waiting for suspend/resume device" issue should be changing the drive mode to AHCI in the BIOS settings, as indicated here.
After changing this, my Ubuntu booted smoothly.

-2

you have to update your grub config and remove swap info (resume=UUID=7e4723c7-...) from /etc/default/grub then update grub sudo update-grub

1
  • Note that the user in question is unable to get into their system to edit that file.
    – Kusalananda
    Dec 12, 2022 at 13:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .