1

Update2:
Registry's changes actually saved. But for entries that will not be permanently stored (that be reset if, for example run wineboot), after regedit (with firejail) is closed, those entries are reset to default.

Example:
If I add a new String value entry called test. The change is saved.
If I modify HKEY_LOCAL_MACHINE>Hardware>Description>System>CentralProcessor>0>VendorIdentifier from AuthenticAMD to None, it does not works with firejail.

Without firejail, the change is saved, but if I run wineboot, it reset to default.


Update:
It seems that changes actually wrote to disk, while modifying registry with regedit (with filejail), I open another regedit, and saw that data was modified. But, after close regedit, the registry is reset.


I'm using firejail version 0.9.56 (default package from Mageia). I have no problem running wine with firejail, except when I want to modify registry. Without firejail, there's no problem, but when I run wine with firejail all modifications revert back to default.

Here is my firejail wine profile:

# Firejail profile for wine
# Description: A compatibility layer for running Windows programs
# This file is overwritten after every install/update
# Persistent local customizations
include /etc/firejail/wine.local
# Persistent global definitions
include /etc/firejail/globals.local

noblacklist ${HOME}/.Steam
noblacklist ${HOME}/.local/share/Steam
noblacklist ${HOME}/.local/share/steam
noblacklist ${HOME}/.steam
noblacklist ${HOME}/.wine
# with >=llvm-4 mesa drivers need llvm stuff
noblacklist /usr/lib/llvm*

include /etc/firejail/disable-common.inc
include /etc/firejail/disable-devel.inc
include /etc/firejail/disable-interpreters.inc
include /etc/firejail/disable-programs.inc

caps.drop all
netfilter
nodvd
nogroups
nonewprivs
noroot

#############
blacklist /media
blacklist /mnt

noblacklist ${HOME}/.wine
whitelist ${HOME}/.wine
noblacklist /tmp/.wine-*
whitelist /tmp/.wine-*

include /etc/firejail/whitelist-common.inc
7
  • Do you get any error messages in the terminal when you try to run regedit?
    – Time4Tea
    Jun 2 '20 at 22:39
  • There's a error message: Error: cannot read UID_MIN and/or GID_MIN from /etc/login.defs, using 1000 by default
    – duqu
    Jun 2 '20 at 23:01
  • I created user for running wine with firejail has UID 555
    – duqu
    Jun 2 '20 at 23:02
  • Ok. Maybe try noblacklisting /etc/login.defs?
    – Time4Tea
    Jun 3 '20 at 0:27
  • It does not work, also this error still appears.
    – duqu
    Jun 3 '20 at 0:39
0

I found a workaround, it does not really solve this problem of running wine with firejail, but it solved problem that I need changes of registry take effect on other applications running inside the same sanbox.

My solution is:

  1. Install Autohotkey.
  2. Make a script, such as:

    ^k::
    Run, regedit
    
    ^j::
    Run, other_application.exe
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.