1

I'm on a HP Probook 640 G5, using Debian 10, with this hardware for wireless:

lspci -nn:

01:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)

I'm wondering if there is a driver for Debian 10 supporting this hardware anywhere?

Thanks!

1
4

According to the comment by Jeff Schaller and the linked information about your Wi-Fi 6 AX200 card, you need at least a 5.1 kernel and a recent firmware-iwlwifi package. Both are available from the backports repository.

  • Follow the instructions of Stephen Kitt's answer to upgrade your kernel from buster-backports, the current version is 5.5.17. It won't hurt to update the firmware packages as well.
  • Then install the firmware-iwlwifi package from backports with

    sudo apt install -t buster-backports firmware-iwlwifi
    
1
  • Thanks! This worked for me. – LukesDiner Jun 10 '20 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.