There seem to be many scenarios, I read quite a few, but I caould not find a match for my problem.

I have this gparted view on my system: gparted screen

I had sda6 swap sit right behind sda5; I moved that sawp space to another disk. Then swapoff and deleted sda6; then extended sda5 to consume the free 8GB... all good so far. These two (sda 5 and sda6) were in the same "extended" partition.

However, allocating the unallocated 256 GB does not work; as I cannot extended the sda3 partition. My understanding is that the 0.25 version of gparted allows for online disk extending. What options do I have? Can this be done on a live system?

  • Yes, try gparted from a live system, partitions /dev/sda[235] appear to be locked. This symbol is new to me, but seems to represent the same state as the "key icon" (as seen here for example).
    – Freddy
    Jun 2, 2020 at 6:55

1 Answer 1


gparted and other partitioning software will be funny about extending logical partitions (those within the extended partition sda3) because the underlying extended partition would need to be extended first with the others still inside.

I suggest, you clone your disk to be safe, boot a live image and try gparted from there. If it still won't work, there's options:

  • Possibly use a lower level partitioning tool (fdisk, sfdisk, parted) which may give you more control
  • annotate the exact start and end locations (and types) of each logical partition (sda5 in this case)
  • delete sda3 and sda5
  • recreate the extended partition to take up as much space as you like, making sure it starts exactly where sda3 started (the new extended partition will also be called sda3)
  • recreate sda5 making sure it starts exactly where it did before
  • make sure all partitions are of the same type as before

And all your data will be where you expect it to be. You might need to extend the file system under sda5 but that's the easy bit.

These primary and extended and logical partition constructs are part of the old DOS disk label that originally supported only 4 partitions. Modern GPT disk labels don't have such limitations and there's no primary or extended partitions or partitions within partitions.

  • Well... I booted from the gparted ISO, then extended the sda3 partition; worked. Then extended the sda5 (except for the last 8GB), and created a linux-swap sda6 with the left over 8GB; green ticks. Then booted normally, but it entered 'emergency mode'... I changed the UUID to the new sda6 id, rebooted... same result: emergency mode. Now what?
    – MaxG
    Jun 2, 2020 at 9:05
  • Huh... all good... booted again, and all it there and in order! Phew.
    – MaxG
    Jun 2, 2020 at 9:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .