0

I am trying to run a Windows application in Wine but it tells me this:

it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"

So as root, I try to install wine32 but I get this:

    $ sudo apt install wine32
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine32:i386 is already the newest version (4.0-2).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 wine32:i386 : Depends: libc6:i386 (>= 2.28) but it is not going to be installed
               Depends: libwine:i386 (= 4.0-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

attempting to install libc6:i386 and libwine:i386 give me errors too:

 $ sudo apt install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc6 : Breaks: libc6:i386 (!= 2.29-7) but 2.28-10 is to be installed
 libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed
              Recommends: libidn2-0:i386 (>= 2.0.5~) but it is not going to be installed
              Breaks: libc6 (!= 2.28-10) but 2.29-7 is to be installed
 libcrypt1 : Breaks: libc6:i386 (< 2.29-4) but 2.28-10 is to be installed
 wine32:i386 : Depends: libwine:i386 (= 4.0-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

And:

    $ sudo apt install libwine:i386
[sudo] password for optiplex: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libwine:i386 : Depends: libc6:i386 (>= 2.28) but it is not going to be installed
                Depends: libfontconfig1:i386 (>= 2.12.6) but it is not going to be installed
                Depends: libfreetype6:i386 (>= 2.6.2) but it is not going to be installed
                Depends: libncurses6:i386 (>= 6) but it is not going to be installed
                Depends: libtinfo6:i386 (>= 6) but it is not going to be installed
                Depends: libasound2:i386 (>= 1.0.16) but it is not going to be installed
                Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgphoto2-port12:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                Depends: liblcms2-2:i386 (>= 2.2+git20110628) but it is not going to be installed
                Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                Depends: libmpg123-0:i386 (>= 1.13.7) but it is not going to be installed
                Depends: libopenal1:i386 (>= 1.14) but it is not going to be installed
                Depends: libpcap0.8:i386 (>= 0.9.8) but it is not going to be installed
                Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                Depends: libudev1:i386 (>= 183) but it is not going to be installed
                Depends: libvkd3d1:i386 (>= 1.0) but it is not going to be installed
                Depends: libx11-6:i386 but it is not going to be installed
                Depends: libxext6:i386 but it is not going to be installed
                Depends: libxml2:i386 (>= 2.9.0) but it is not going to be installed
                Depends: ocl-icd-libopencl1:i386 but it is not going to be installed or
                         libopencl1:i386
                Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
                Recommends: libcapi20-3:i386 but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libdbus-1-3:i386 (>= 1.9.14) but it is not going to be installed
                Recommends: libgl1:i386 but it is not going to be installed
                Recommends: libglu1-mesa:i386 but it is not going to be installed or
                            libglu1:i386
                Recommends: libgnutls30:i386 (>= 3.6.5) but it is not going to be installed
                Recommends: libgsm1:i386 (>= 1.0.18) but it is not going to be installed
                Recommends: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libjpeg62-turbo:i386 (>= 1.3.1) but it is not going to be installed
                Recommends: libkrb5-3:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libodbc1:i386 (>= 2.3.1) but it is not going to be installed
                Recommends: libosmesa6:i386 (>= 10.2~) but it is not going to be installed
                Recommends: libpng16-16:i386 (>= 1.6.2-1) but it is not going to be installed
                Recommends: libsdl2-2.0-0:i386 (>= 2.0.9) but it is not going to be installed
                Recommends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
                Recommends: libv4l-0:i386 (>= 0.5.0) but it is not going to be installed
                Recommends: libvulkan1:i386 but it is not going to be installed
                Recommends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
                Recommends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
                Recommends: libxfixes3:i386 but it is not going to be installed
                Recommends: libxi6:i386 but it is not going to be installed
                Recommends: libxinerama1:i386 but it is not going to be installed
                Recommends: libxrandr2:i386 but it is not going to be installed
                Recommends: libxrender1:i386 but it is not going to be installed
                Recommends: libxslt1.1:i386 (>= 1.1.25) but it is not going to be installed
                Recommends: libxxf86vm1:i386 but it is not going to be installed
                Recommends: libgl1-mesa-dri:i386 but it is not going to be installed
                Recommends: libasound2-plugins:i386 but it is not going to be installed
 wine32:i386 : Depends: libc6:i386 (>= 2.28) but it is not going to be installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Doing apt --fix-broken install works but does not fix libc6 or libwine after running them again.

I know there are other answers and forum posts on the same thing and I have tried using their solutions but I don't get anything new.

Can someone help me fix or work around this?

Thank you for your time!

I am running Debian 10 on an Optiplex 755

EDIT

Output of apt policy libc6:{amd64,i386} : (As asked by Stephen Kitt)

$ apt policy libc6:{amd64,i386}
libc6:
  Installed: 2.29-7
  Candidate: 2.29-7
  Version table:
 *** 2.29-7 100
        100 /var/lib/dpkg/status
     2.28-10 500
        500 http://ftp.au.debian.org/debian buster/main amd64 Packages
libc6:i386:
  Installed: (none)
  Candidate: 2.28-10
  Version table:
     2.28-10 500
        500 http://ftp.au.debian.org/debian buster/main i386 Packages
1

Your setup is somewhere between Debian 10 and the forthcoming Debian 11, with package versions which are no longer available from repositories. Packages for multiple architectures (amd64 and i386, in this case) need to be installed in exactly the same version, and that’s no longer possible in your system’s current state.

Assuming your desired state is Debian 10, you need to downgrade every package which can’t be installed:

sudo apt install libc6/stable

etc.

Once that’s done, you’ll be able to install wine32.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.