I am using xfce terminal on one side of screen, and many tabs. But when I want to use EOF interupt (aka <ctrl>-<Shift>-D), then the tab will remove its position from that side of screen to the other (see image below), I have even try to set -o ignoreeof but to no avail.

Before <ctrl>-<Shift>-D: enter image description here

after <ctrl>-<Shift>-D: enter image description here

As you can see, the first tab Terminal will get off the right side of screen to the other, only because of <ctrl>-<Shift>-D. Is there a way to fix this bug? (that is -> the tab where is EOF interupt triggered (Terminal in my case), will stay at its position (will be fixed), without moving randomly on the screen)? This is really annoying. Again - I do not want do disable EOF terminal at all, but rather disable to shift of the tab (where it was triggered) to another part of screen. Thanks in advance!

  • Taking a look at xfce terminal (version, I noticed that the file menu lists the keyboard shortcut for Detach Tab as Shift+Ctrl+D. Is it possible that you're somehow pressing a shift key while pressing <ctrl>-D or that your keyboard is somehow damaged and causing an adjacent shift key to act as if being pressed when a control key is pressed? – David Yockey Jun 1 at 12:39
  • @DavidYockey my bad, I will edit. I am pressing the shift (because it is the default shortcut for EOF interrupt), So the question is correct, except instead of Ctrl-D, there will be Shift-Ctrl-D, anyway, how to diesble the movement of tabs after pressing it? – autistic456 Jun 1 at 18:13

Don't have a fix, but this partial answer might be of some use, or at least provide some explanation for what's happening.

The effect you're seeing seems not to be a bug but instead due to "smart placement" of windows. I don't know if there's a way to completely disable smart placement or to have a moved tab appear in a window exactly overlapping the original window, but the behavior can be controlled to an extent.

There's a slider control on the Placement tab of the Window Manager Tweaks utility where the size of windows that trigger smart placement can be set. If the size is set toward the small end, the effect you describe occurs. Setting a sufficiently large size causes the moved-tab window to appear either at the center of the screen or under the mouse pointer depending on the radio button selected on the same tab. If the mouse pointer is over the original terminal window with the two tabs when the <ctrl>-<Shift>-D shortcut is executed, the moved-tab window will appear overlapping the original window more or less depending on the location of the mouse pointer at the time.

| improve this answer | |
  • thanks, that is partiall solution. It solved the displacment, but not the fact, tab itself will not stayed in original one. That is - the tab (after ^D) will "pull out" to a separate terminal (and thus causing to have 2 terminals now), after which I have to exit from it. So I accepted it as it solve at least the issue with random displacement – autistic456 Jun 4 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.