0

I just got a old HP Pavilion x360 that I really want to put linux on, but I'm having problems with the cursor jumping sporadically and clicking things without me touching the touchpad. I tried to install openSuse, Xubuntu, and arch. All three had the same issue. I tried disabling the touchpad, but the problem still occurs.

I installed synaptic drivers and attempted a fix on arch from here: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Cursor_jump. No solutions have worked.

I'm using xfce4 with xorg as the display manager on my arch install.

Any help is greatly appreciated because linux is currently unusable. Right now I have Arch installed on the hard drive and an arch live usb to work toward a solution with. Thank you!

Edit: Solved! Just had to disable the touchscreen

6
  • What display server do you use on Arch ? X11, Wayland, ... Did you try modifying the mouse driver's parameters, for example to disable acceleration ? This is a typical problem on old hardware. Either that or your mouse pad has reached retirement age ... It happens. If not and you use X11, then give me a holler and I will guide you through possible modifs. – Cbhihe May 30 '20 at 20:31
  • Note that unless you chroot from you live Xubuntu, you will need to work from your Archlinux install for changes to stick and trials to actually mean anything. Going from Xubuntu to Archlinux may actually change what the final solution might be. – Cbhihe May 30 '20 at 20:34
  • Can you detail what you mean when you write: "I attempted to turn off the touchpad, but the problem still occurs." Do you mean you could not turn it off, or you did, checked that you really did and still had the same issue ? – Cbhihe May 30 '20 at 20:40
  • Is that the right model number? I just bought that model for my daughter like two weeks ago - a convertible w/ touchscreen etc? If so, the touchscreen might be the issue more than the trackpad. – Aaron D. Marasco May 30 '20 at 21:09
  • @Cbhihe I am currently using xorg as my display server. The computer is from 2015 so I'm not sure that it is old enough for the hardware to be wearing, it works perfectly fine in Windows. By turning off the touchpad, I meant that I disabled it and the problem was not solved. And as for the xubuntu, I can replace it with the Arch installer so I can Chroot easier without crossing distros. – sammydsssss May 30 '20 at 21:15
1

I found that the culprit was the touchscreen and not the touchpad. The problem was solved by disabling the touchscreen. Luckily I wanted to do that anyways because I hate touchscreens.

2
  • Well done. I should have checked out yr machine's specs and seen you had a touch-screen there. I had falsely assumed you had only the usual two suspects in the way of pointing devices: mouse and mousepad. In any case know that you can probably still solve the problem instead of "suppressing" it by disabling the 3rd pointing device, i.e. your touch screen. It involves tweaking the pointing devices' acceleration and threshhold and persisting those tweaks. ;-) (PS: I profoundly dislike touch screens as well.) – Cbhihe May 31 '20 at 9:30
  • Glad I could help. I was confused because you said "old" when I literally just bought one. Sounds like they (stupidly) keep re-using the number and upping the specs because the one I just bought is 10th Gen i5, which didn't come out until late 2019. – Aaron D. Marasco May 31 '20 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.