14

I'm stuck in the boot and can't open any terminal. When I try to boot my laptop it shows the following error:

Gave up waiting for root device. Common problems:
-Boot args (cat /proc/cmdline)
  -Check rootdelay= (did the system wait long enough?)
-Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=718ed077-947d-4018-80ad-59825678e81d does not exist. Dropping to a shell!

BusyBox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3.2) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)_

I tried to follow these steps mentioned in this link (https://forums.linuxmint.com/viewtopic.php?t=47594). They changed root=UUID=9c05139c-b5bb-4683-a860a7bdf456ccda ro quiet splash to root=/dev/sda5 (i used my UUID and /dev/sda1), but then the error becomes:

-Missing modules (cat /proc/modules; ls /dev)
ALERT! root=/dev/sda1 does not exist. Dropping to a shell!

(I tried to find out my root partition where I installed ubuntu, but i can't run fdisk command in initramfs and also i tried running

(initramfs) cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.3.0-53-generic root=UUID=718ed077-947d-4018-80ad-59825678e81d ro quiet splash

and

(initramfs) cat /proc/modules
(shows nothing)

)

This is where I changed the root=UUID=718ed077-947d-4018-80ad-59825678e81d ro quiet splash to root=/dev/sda1 (only the line started with linux)

enter image description here

1
  • I frequently experience this issue. GRUB messes up the root devices. Outdated and wrong IDs appear. Correcting them root entries manually (cumbersome) most times did the job Apr 23, 2022 at 18:48

2 Answers 2

22

I did the following to fix my error, which I got after flashing a new BIOS.

  1. Enter reboot in the prompt
  2. Goto BIOS setup
  3. Goto SATA Configuration
  4. Change to AHCI
  5. save and restart.
11
  • 2
    Hey, this really works, can you explain better why? Mar 17, 2021 at 20:54
  • 1
    It could be because of newer linux not having support for IDE interfaces at times. not sure though Mar 19, 2021 at 6:42
  • 3
    No idea how problem occurred. No idea how the problem got solved. Weird world. Thanks though :)
    – debugger
    Jul 5, 2021 at 5:39
  • 1
    may be this could help diffen.com/difference/AHCI_vs_IDE Oct 22, 2021 at 14:23
  • This fixed me, much appreciated. I think I originally got into this situation from either installing some updates (via terminal apt-get instead of or in addition to the UI semi-automated package installations) or from the laptop crashing whenever power got too low -- I couldn't seem to figure out how to tell it to act like a normal computer and just shut down when power got too low -- i.e. don't crash. May 18, 2022 at 6:35
7

Your empty output from cat /proc/modules indicates you have no kernel modules loaded, so something has gone wrong with either initrd file generation when installing your current kernel, or with hardware detection as the kernel starts up.

You might try running modprobe ahci to try and force loading the standard AHCI SATA driver, but I'd expect it to just tell you that the module ahci was not found.

If you have other kernel versions available in your GRUB boot menu, now would be a good time to try them. If the GRUB boot menu has "Advanced options for " item, select it: it should bring up a sub-menu of all kernel versions you have installed. Typically there are two boot menu items for each kernel version: one normal boot and another for booting into recovery mode. If there is a kernel version older than 5.3.0-53 available, try the normal (non-recovery mode) option for it.

If the system now boots up normally, it confirms that there was a problem with creating the initrd file during the installation of the latest kernel update. But that should be fairly easy to fix: first run sudo apt-get clean to clean up the package manager's cache: anything in that cache can just be downloaded again if necessary, and over time the cache can sometimes grow very large, so cleaning it up is a good first step.

Then run df -h and make sure that any of the filesystems on your system disks is not 100% full. Finally run sudo update-initramfs -k 5.3.0-53-generic -u to re-build the initramfs file for the kernel version 5.3.0-53. If that command completes without any error messages, you should now be able to boot normally with the latest kernel version you have.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .