0

I am new to Linux and I am using Debian Testing with KDE Plasma installed during the installation process(i.e. tasksel).

I had a problem with my brightness controls (the Fn keys or the brightness slider was not working too) so after googling I finally got a solution. And that was to create a file 20-intel.conf in /usr/share/X11/xorg.conf.d with some text in it and after a reboot the Fn keys and slider started working/changing the brightness.

But I noticed an issue after doing this: After login when the KDE Plasma Splash screen started flickering after the loading(circling) was over and even the kde application launcher, the panel started flickering when I hovered mouse on them (but a little fast).

So I removed 20-intel.conf file, rebooted and all the flickering stopped. But I need to change the brightness too. Also the brightness file in the intel_backlight has 4422465 which seems strange to me. Also there is another folder named acpi_video0 in /sys/class/backlight but its brightness file has value 7.

So how do I enable brightness control as well as fix the flickering issue too? Does it have something to do with the acpi_video0 folder or do I need to add its conf file and if yes what should it contain...

Thank You in advance..!!!

0

Ok, So I fixed the problem myself... Just need to make a change in '20-intel.conf' file.. For those who wanna fix this... Here's goes the Solution: First check whether your laptop's back-light is detected or not by your OS kernel. The folder '/sys/class/backlight' should not be empty. An empty '/sys/class/backlight/' folder indicate backlight hardware is not detected. If so please add this two option "video.use_native_backlight=1 acpi_backlight=vendor" (without quotes) in grub command line before system boot up. Press 'e' to edit the grub command line before your system boot and add the above options after "quiet splash". After edit last part of your grub command line shall look like

....quiet splash video.use_native_backlight=1 acpi_backlight=vendor....

Then boot the system. You shall find some content under 'sys/class/backlight/' folder now. Now edit '/sys/class/backlight/intel_backlight/brightness' to change brightness. Or for permanent solution you can do the following steps... Basically it works creating the /usr/share/X11/xorg.conf.d/20-intel.conf file with the following lines:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "intel_backlight"
EndSection

Save the file, exit an restart...

If the screen starts tearing or flickering after the restart then add the following line:

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"     "sna"
        Option      "Backlight"       "intel_backlight"
        Option      "TearFree"        "true"
EndSection

Even after this if it's flickering then change 'sna' to 'uxa' and remove the Tear Free Line, like this:

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"     "uxa"
        Option      "Backlight"       "intel_backlight
    EndSection

After doing this again restart your PC/Laptop. If this still doesn't solve your problem then try changing 'uxa' to 'blt' and again restart... Any one of these three will solve your problem Reference: https://wiki.archlinux.org/index.php/intel_graphics

This makes the brightness slider and the Fn keys to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.