2

I am trying to use gnuradio-companion on a remote compute node running ubuntu 18.04.1 LTS. I ssh into the server with the command:

ssh -p 22 address.net -X

And when I open gnuradio-companion, the icons do not show up:

enter image description here

I've tried compression (-C) and -Y, but I am not really experienced with X11 forwarding so not sure what im doing. Im using a thinkpad p1 running Ubuntu 20.04 to access the server and all my packages are up to date. I've also tried disabling discrete graphics along with reinstalling x11 related packages. Any help would be appreciated!

3
  • It might be that the icons are actually in a font and that font is not on your thinkpad. If possible, install gnuradio-companion also on the thinkpad, even though you continue to run it on the remote.
    – meuh
    May 29 '20 at 17:03
  • @meuh thanks for the reply. I installed gnuradio on my thinkpad, restarted, and still have the same issue. I opened up gnuradio-companion to confirm it is working on my thinkpad. This doesn't happen to anyone else I know May 29 '20 at 20:09
  • Looking at what might be the source for the icon setup code in Python, it could be that it is using the gnome icons, like 'document-new' which would be /usr/share/icons/gnome/16x16/actions/document-new.png etc. If you dont have this directory on the server try installing a package like gnome-icon-theme.
    – meuh
    May 31 '20 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.