I boot up my CentOS 7 PC and on startup, it shows me this error (see image) - if I press CTRL+D, it boots up fine. Is there a way to clear this message or default it to starting up normally because the entire computer works fine, just after CTRL+D. See image below:

enter image description here

The journalctl -l -xb log can be found at the LINK below because there was too much text entered:


My /etc/fstab/ file:

# /etc/fstab
# Created by anaconda on Tue Dec 11 14:28:31 2018
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
UUID=4d48ab0d-e1ab-4d7e-9f64-8481a7690060 /                       ext4    defaults        1 1
UUID=a7fad550-81d7-4150-8b76-e89584e4cfdf /boot                   ext4    defaults        1 2
UUID=0baabbc4-2dc0-4971-9d2b-c123e5ad7355 /home                   ext4    defaults        1 2
UUID=7756eafb-382c-46b3-aae8-e44d7e2cfe06 swap                    swap    defaults        0 0


Thanks @terdon - does this help?

I've also run systemctl default, systemctl reboot and reboot.

  • Have you tried looking at the logs as the error message suggests? I can see two errors reported, but can't tell more since you're not providing any information. Please edit your question and add some relevant details from the logs. Also, please show us your /etc/fstab file, looks like you might have an issue with one of the tmpfs mounts.
    – terdon
    May 28 '20 at 8:19
  • @terdon I'll have a look at that for you - all I need to know is how to dismiss/clear/sort it because it's not affecting the machine's running.
    – ekv_56
    May 29 '20 at 13:54
  • Yes, well the way to stop getting an error is usually to fix whatever is causing that error. Which is why the logs would be relevant to figure out what is actually happening.
    – terdon
    May 29 '20 at 14:05
  • @terdon - Should I just take a picture of the output from journalctl -xb?
    – ekv_56
    May 29 '20 at 14:11
  • No, please don't post images of text. Instead, paste the text directly into your question and use the formatting tools to format it as code. Don't forget to also include your /etc/fstab as I asked you yesterday.
    – terdon
    May 29 '20 at 14:12

There are still cut-off lines in your log output file, but the log confirms the problem happens while the system is still running in initramfs mode (i.e. early in boot, before mounting the real root filesystem).

So the problem seems to be not related to how your actual /etc/fstab file is set up right now, but it might be caused by how it was when your current kernel package was installed, as at that point a number of configuration files are packaged into the initramfs file. Or it might be because of some other error in the scripts used as components of your initramfs file, or the system running out of disk space while it was building your initramfs file.

Fortunately, rebuilding your initramfs file is easy. First backup the old one:

cp -p /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).img.bak

Make sure you're not running out of disk space in /tmp or /var/tmp, then tell dracut to create a new one for you:

dracut -f

Any messages at all are going to be indications of problems - if dracut works for a while and produces no messages at all before the prompt returns, it was successful.

  • Thanks but no luck - did both commands and they ran without any problems. Rebooted and still get the same error appear. - CTRL + D still boots up though. Any suggestions?
    – ekv_56
    Jun 1 '20 at 7:16
  • You might want to look for the word "huge" everywhere under /etc and /usr/lib/dracut to see where it might be coming from: grep -r '^[^#]*huge[^pt]' /etc /usr/lib/dracut. This command will look for uncommented instances of the word "huge" that are not parts of words hugepages or hugetlbfs. You may get some false hits (e.g. /etc/mke2fs.conf) but the results might give some clues on where to look.
    – telcoM
    Jun 1 '20 at 8:23
  • Thanks but what do I do when I get a hit?
    – ekv_56
    Jun 1 '20 at 12:15
  • If you don't know, please add the results to your question so we can see it too. But if it turns out the results remind you of something you've done earlier and know how to undo (and suspect it's relevant), you could try undoing that change, possibly recreating the initramfs again, and then seeing if that fixes the problem.
    – telcoM
    Jun 1 '20 at 12:31
  • Thanks - I'll have a go in a bit and let you know the outcome. - O
    – ekv_56
    Jun 1 '20 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.