It would be fantastic if someone could help.

To give some history as to why; I had a problem with my keyboard mapping using TightVNC and so attempted to install tigerVNC and turboVNC on my BeagleBoneBlack (BBB). Below is the link to the keyboard issue I had and also the version of Linux that is currently on my BBB.

Link to Keyboard mapping issue in this forum

Linux beaglebone 4.14.71-ti-r80 #1 SMP PREEMPT Fri Oct 5 23:50:11 UTC 2018 armv7                                l GNU/Linux

I am only just entering the world of Linux (considering running a separate partition with Ubuntu for this type of development) so I am a problem missing some key foundations as to how to install these packages from the command line.

I have tried things like the below and iterations of, and always get the same message Unable to locate package tigervnc-common :

sudo apt-get install turbovnc
sudo apt-get install tigervnc

I also looked at the below link from TurboVNC at the digital signatures however this left me a confused with the PGP links and the even sudo apt-get install debsig-verify gave me the former error message:

TurboVNC Digital Signatures

Can anyone set me straight?

Many thanks in advance for even considering a reply!

P.s. I am accessing the terminal window via an SSH (PUTTY) and the BBB is connected directly to the router.

1 Answer 1


Ok so the solution that worked for me was found from the below this link

sudo apt remove qterminal
sudo apt autoremove
sudo apt install lxterminal

When I then restarted my BeagleBone Black I did not have the same keyboard issue with lxterminal.

The end of rather a long but informative saga.

  • Juts to add to this in case anyone else has the same problem I continued using tightVNC on the BeagleBone and used tiger VNC on my PC but I think ant tight vnc derivative would do.
    – Reowald
    May 30, 2020 at 10:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .