0

I work remotely on a virtual machine running gnome 3.28.2 on RHEL Server 7.6, the issue occurred when logging in.

I have no taskbar, background, or topbars on any windows, meaning I cannot close or resize any windows and I cannot logout. I can move terminals, but no other windows, and many windows will not alter their z-position when I try to use windows underneath. Alt+tab will not allow me to switch windows either.

I have spent several days searching for answers and trying the fixes found here and elsewhere for similar issues but no such luck!

All other users are unaffected, and rebooting the machine did not solve it. Because of the other users, I am unable to do any more reboots or make changes to anything outside of my /home so as not to affect their work.

I appreciate the first response will likely be the classic "provide more information", but I am not sure what that would be, so any pointers would be greatly appreciated!

enter image description here

0

It looks like your window manager exited/crashed, and the session saved is not launching it. Can you run metacity —replace in a terminal to start one up?

| improve this answer | |
0

Thanks! I ran metacity replace and it gave me top bars and the ability to move windows and close them, but no taskbar/logout, so a step in the right direction!

I then solved it by backing up my .config, .cache, .local and .Xauthority, deleting them, then using pkill -u myname, and logging in. Everything reconfigured and I was able to copy a few configs from backup for the likes of terminator. Still not sure exactly what the problem was!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.