10

Context

I have recently updated from Fedora 31 to Fedora 32 (on a Thinkpad X1 Carbon — but I'm not sure it's relevant).

Problem

Since the update, I'm experiencing beeping alarm sound at apparently random times; which is quite annoying.

What I've noticed so far:

  • The alarms sounds like “a digital watch alarm”, as described in this subreddit. However, unlike what the feedback comment says, it didn't stopped after a dnf upgrade for me. Moreover, I've only used post-released Fedora 32, and not beta (as in the subreddit).
  • The alarm sound is different from the terminal bell / alert sound.
  • The alarm goes off about a couple times a day. It lasts around 10 seconds. Time seems consistent from day to day, and to occur at “round times”: e.g., 08:50, 12:15, etc.
  • Alarms do not seem to be related to any calendar event. As far as I remember, they were still here when I uninstalled GNOME-Calendar.

  • Alarms are not related to GNOME-Clocks alarms.

  • There are no cron jobs running (neither for my user, nor for root)

Questions

What causes these alarms? How to disable them?

5
  • Well, it rang at 10:03 today, so I guess the part about regularity is wrong…
    – ebosi
    Commented May 27, 2020 at 9:04
  • 1
    The sound I hear is actually the /usr/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga file playing. I'm still investigating which program causes it to be played.
    – ebosi
    Commented Jun 28, 2020 at 17:09
  • OMG. I have the same issue and it's so painfully annoying. For me it always triggers 5min before the daily team meeting. Any solution is appreciated here! Commented Oct 14, 2020 at 8:59
  • 1
    I've opened: gitlab.gnome.org/GNOME/gnome-calendar/-/issues/652 Commented Oct 14, 2020 at 9:12
  • @JulianStecklina the quick (and dirty!) solution is to delete/rename the file so that it effectively cannot be played any more. Or replace it with Pachelbel's cannon, as you wish…
    – ebosi
    Commented Oct 14, 2020 at 16:40

2 Answers 2

7

In my case, the program playing it was Evolution. The sounds can be turned off in Evolution 3.34.1 and higher (unreleased at the time of writing) in the Settings or via:

gsettings set org.gnome.evolution-data-server.calendar notify-enable-audio false

Here's a general approach to find out what program causes it:

  1. Install auditd (usually the audit or auditd package)

  2. Configure a watch on the sound file by creating /etc/audit/rules.d/alarm-clock.rules with the following content:

    -w /usr/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga -p rwxa -k alarm-clock
    

    And load the rule:

    $ sudo augenrules --load
    
  3. Wait for the sound to happen

  4. Check the audit log:

    $ sudo grep alarm-clock /var/log/audit/audit.log
    type=SYSCALL msg=audit(1604335160.733:102): arch=c000003e syscall=257 success=yes exit=13 a0=ffffff9c a1=23ce800 a2=0 a3=0 items=1 ppid=1664 pid=2045 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm="evolution-alarm" exe="/usr/libexec/evolution-data-server/evolution-alarm-notify" subj==unconfined key="alarm-clock"
    type=PATH msg=audit(1604335160.733:102): item=0 name="/usr/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga" inode=3213038 dev=00:24 mode=0100644 ouid=0 ogid=0 rdev=00:00 nametype=NORMAL cap_fp=0 cap_fi=0 cap_fe=0 cap_fver=0 cap_frootid=0
    

    The comm= and exe= elements may point to the culprit.

2

Uninstalling gnome-clocks solved the random alarm at 11:00 for me.

There is an issue at https://gitlab.gnome.org/GNOME/gnome-clocks/-/issues/102 which got closed unfortunately.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .