0

I am dual booting my Windows 10 laptop and I chose the Linux Mint 19.3 distro to run alongside windows with the dual boot option. When I boot into Linux I'm not having any success connecting to my USB printer which is a LaserJet M1212nf MFP and that printer is supported by HP.

I've got hplip 3.17.10 and hplip-gui 3.17.10 installed and I also ran hp-plugin to install the plugin. When I run hp-setup from the command line I select USB on page one and then when I click on Next I get a "No devices found" message. Just for good measure I plugged in my usb printer before running hp-setup.

Update: I've tried running hplip.3.20.5.run and I'm getting this message:

Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed. Package-Name Component Required/Optional
xsane scan OPTIONAL
python3-notify2 gui_qt5 OPTIONAL
python3-pyqt4-dbus gui_qt4 OPTIONAL
python3-pyqt4 gui_qt4 REQUIRED
python3-pyqt5-dbus gui_qt5 OPTIONAL
python3-pyqt5 gui_qt5 REQUIRED
python3-dbus fax REQUIRED
python3-reportlab fax OPTIONAL
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y

INSTALL MISSING REQUIRED DEPENDENCIES

note: Installation of dependencies requires an active internet connection. warning: Missing REQUIRED dependency: python3-pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x)) warning: This installer cannot install 'python3-pyqt4' for your distro/OS and/or version. error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

I checked to see if I have python3-pyqt4 installed and it looks like I do:

(base) david@david-Inspiron-3520:~/Downloads$ dpkg -l | grep python3-pyqt4 ii python3-pyqt4 4.12.1+dfsg-2 amd64 Python3 bindings for Qt4

Please let me know your thoughts!

Thanks,

David

0

Recommend taking a look at the HP community web site. If you search for HPLIP 3.19.12 (Linux Mint 19.3): Plugin installation failed & scroll down to Problem solved, there is a list of commands which may help resolve your issue.

Also worth noting for future reference that before installing new version of hplip, hp recommend removing any older versions of hplip related packages to avoid possible conflicts with the new version.

$ sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds \
libsane-hpaio printer-driver-hpcups printer-driver-hpijs
$ sudo rm -rf /usr/share/hplip/
$ sudo apt-get autoremove
1
  • Thanks, annahri. I get the error message "warning: Missing REQUIRED dependency: python3-pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))." But when I execute the command "dpkg -l | grep python3-pyqt4" I see that python3-pyqt4 is installed. Also, HPLIP 3.19.12 is for Linux Mint 19.2 (Tessa) and there is no option during the install for Linux Mint 19.3 (Tricia). Thanks! – David Watson Jun 22 '20 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.