-1

I have a very old 2012 model of dell inspiron pc with 2 gb ram running windows 10. Today I installed Android x86 (dual boot with windows 10). I installed the grub bootlader in Windows directory. And yes my pc is non efi. I used android x 86 and everything was right. But when I started my pc again the Dell logo appeared as usual, but after this the screen has some text like this (I can't remeber the exact text):

Grub loading...

Error 16

Then I googled a lot and tried a lots of things but nothing worked then I installed android x86 again but this too didn't worked I again googled and I followed a guide (I can't remember what was it) and now I have get rid of "error 16" problem but now the screen is showing something like this...

Minimal bash like line editing is supported.....bla...bla...bla

Again I searched a lot but couldn't find anything to solve this problem. And I don't have windows 10 installation disk. But I have a Fedora iso file in my laptop so I made a bootable image of Fedora in a pen drive and used it as live os in the pc to access files now I can access the hard disk but I don't know if there is some way to find and manually delete the grub bootlader from local disk C. And now whenever I type boot in the 'minimal bash' screen it says something like there are no bootable os. I'm totally confused. I can't even get it fixed by someone due to lockdown. Please help me.

I want to delete the grub bootloader and Android x86 and get my windows 10 back with all personal files or some way to boot fedora as only os without losing the personal files.

And yes I read this in a forum that I can remove grub bootloader from command prompt in windows so I want to ask if there is any way to manually remove grub bootloader using fedora and replace it with windows default bootloader.

Thanks a ton in advance.

1 Answer 1

0

I have fixed it today myself by making windows 10 recovery drive using my laptop and then booted my pc with the drive and then I typed the following commands in the command prompt which appeared in the repair menu

bcdedit /export c:\bcdbackup
c:
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec.exe /rebuildbcd

And now I'm back with my Windows 10 and the GRUB has been removed forever :)

PS: My laptop was HP Pavilion with Windows 10 Home Edition while my Desktop (Dell) was running Windows 10 Enterprisre Edition.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .