0

Show debian version in my pc:

lsb_release -a 
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.0 (stretch)
Release:    9.0
Codename:   stretch

Show libjetty9-java's version:

dpkg -l  libjetty9-java
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libjetty9-java 9.2.21-1+deb all          Java servlet engine and webserver

An app want to install more advanced version:

Depends: libjetty9-java (>= 9.4) but 9.2.21-1+deb9u1 is to be installed

How can i install libjetty9-java (>= 9.4) in my stretch ?

1 Answer 1

1

This isn’t a generalisable answer, but in this particular case, you can download and install the Debian 10 version of the package:

wget http://deb.debian.org/debian/pool/main/j/jetty9/libjetty9-java_9.4.15-1_all.deb
sudo dpkg -i libjetty9-java_9.4.15-1_all.deb

Its dependencies will already be satisfied on your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.