I have an existing Dell Precision 690 workstation setup to dual boot Windows XP and CentOS 5.5. These operating systems are installed on two separate drives. I have a grub menu on the Linux drive with it set as drive 1 and points to the windows boot info on drive 2.

I tried taking the linux drive and installing it in a new HP Z800 workstation to see if I could be lucky enough to get it to boot, but it didn't. Immediately after it starts to boot I get a few errors.

Here is what the system shows:

Right after this message Red Hat nash version starting I get the following lines:

Unable to access resume device (LABEL=SWAP-sda2)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Is there something I can tweak to get this to possibly boot? I'd really like to not have to reload CentOS 5.5 and the specialized software on this machine.

I do have a grub menu setup on this drive, could this by chance be my problem? The drives in the old machine are setup with Linux as drive 1, and Windows as Drive 2, and the Linux drive hosts the grub menu allowing me to boot to Linux or Windows. Could this some how be the problem?

I do know of a way around this with Windows: install a secondary HDD controller card in the machine, install the drivers, hooked up drive to controller in old machine and make sure it boots, move the drive and controller to the new machine and boot off it, load the motherboard drivers (specifically the hdd controller drivers) and then you can take out the controller card, connect the hdd directly to the motherboard and you're set. This same thing is probably accomplish able in Linux, but I'm not sure. This might be a last ditch effort to try if nothing else works.

  • So you did not unplug the original drive on the HP Z800 and now have 2 hard drives there?
    – phunehehe
    Commented Jan 15, 2011 at 3:32
  • The HP Z800 has 2 1TB drives in a RAID0 configuration, I just added the Linux drive to the third SATA connection basically. I then hit F12 for the boot menu and selected the drive to boot from it...
    – DemiSheep
    Commented Jan 18, 2011 at 1:48

1 Answer 1


If you get this far, it means the bootloader loaded the kernel and initrd/initramfs successfully, but the kernel is not finding the root device. So you should be able to boot by passing something like root=/dev/sda42 on the kernel command line.

At the Grub prompt, edit the entry for Linux, and look for the line that begins with linux. On that line, there should be a parameter that looks like root=/dev/sda42. Change it to root=/dev/sdb42, i.e. a different drive. The current letter might not be a, and the letter that works might not be b, though if you have two drives you'll probably just need to swap sdb for sda or vice versa.

The order of the drive letters in Linux is unrelated (or at least not directly related) to the order in the BIOS, in Grub or in Windows (it depends on the order in which the drivers are loaded). (There are ways around this, but they won't help you right now.)

When you boot, you might get errors if entries in /etc/fstab don't match the current disk device names. If you're not able to get to a repair console, reboot and (in addition to the root= change) add init=/bin/sh to drop directly to a shell, then run

mount /proc
mount -o remount,rw /
vi /etc/fstab    # or whatever your favorite editor is
  • Before I do anything does this give you any other ideas, my grub setup: title Winddows XP rootnoverify (hd1,0) map (hd0) (hd1) map (hd1) (hd0) chainloader +1 I can post my actual configuration tomorrow maybe..
    – DemiSheep
    Commented Jan 20, 2011 at 23:41
  • @DemiSheep: Since the Linux kernel starts, your configuration of Grub is ok. It's the configuration of the Linux system (kernel command line), which is also stored in the Grub configuration file, that needs to be changed for your disk arrangement. Commented Jan 20, 2011 at 23:52
  • I am confused on what to edit exactly - see these links and let me know what I should do: 1: ( i461.photobucket.com/albums/qq337/demisheep/1.jpg ) 2: ( i461.photobucket.com/albums/qq337/demisheep/2.jpg ) 3: ( i461.photobucket.com/albums/qq337/demisheep/3.jpg ) 4: ( i461.photobucket.com/albums/qq337/demisheep/4.jpg )
    – DemiSheep
    Commented Jan 21, 2011 at 17:38
  • Ugh!! Ok, so I thought I had tested the ghosted drive, but it seems I didn't. I went ahead and tested the ghosted drive in the old machine and sure enough I am having the same problem so it seems the ghost failed. I am reghosting it now and will test it ont he same machine before moving it to the new machine. I'll send an update when this is done and I may end up starting a new thread depending on what issues I run into from there. Sorry for any inconvenience I may have caused.
    – DemiSheep
    Commented Jan 21, 2011 at 19:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .