2

When I launch tmux from the terminal, and attempt to move the cursor between words on one terminal line, the shortcuts that work in a default terminal don't appear to apply. e.g. esc + b does move the cursor one word back(albeit with a terminal bell) but esc + f doesn't move it one word forward. Ctrl + a doesn't move the cursor to the beginning of the line, neither does Ctrl + e to the end of the line and so on. I tried the equivalent of Home i.e. fn+ but that capitalizes the next letter and the equivalent for End which is fn+ capitalizes the entire word and moves to the next word. I don't even get the recursive search on trying Ctrl + r.

%cat ~/.tmux.conf
setw -g mouse on
setw -g mode-keys vi
set-option -g prefix C-b

tmux -V
tmux 3.1b

Terminal Version:Version 2.10 (433) on MacOS Catalina

4
  • 1
    So what happens when you put your shell back into emacs mode? (-: – JdeBP May 24 '20 at 8:55
  • @JdeBP It works 🙈. But why does everything fall apart (including the recursive search) if vi mode is enabled? – Zoso May 24 '20 at 11:33
  • That question takes a falsehood as its premise. Nothing has fallen apart in the first place. – JdeBP May 24 '20 at 15:00
  • @JdeBP Thanks, got it. I'd set the VI mode in the ZSH shell which was causing this issue (which was using the VIM bindings). Referring to the VIM mode key bindings of ZSH resolved it. – Zoso May 24 '20 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.