I've tried several cables and I am pretty certain the NIC/OS is the problem. My NIC in my mobo supports 1Gbps but when connected to my homeplug (Devolo Magic 2 Wifi, deffo support GB ethernet), it always shows in KDE OS system tray icon as being connected in 100Mbps mode.

I've ran ifconfig below

enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::7285:c2ff:fec8:1023  prefixlen 64  scopeid 0x20<link>
        ether 70:xx:xx:xx:xx:23  txqueuelen 1000  (Ethernet)
        RX packets 138995  bytes 119279125 (119.2 MB)
        RX errors 0  dropped 142  overruns 0  frame 0
        TX packets 201518  bytes 233657407 (233.6 MB)
        TX errors 6  dropped 0 overruns 0  carrier 2  collisions 7086

lspci -v :

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
        Subsystem: ASRock Incorporation Motherboard (one of many)
        Flags: bus master, fast devsel, latency 0, IRQ 36
        I/O ports at f000 [size=256]
        Memory at f7504000 (64-bit, non-prefetchable) [size=4K]
        Memory at f7500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 23-10-c8-c2-85-70-00-00
        Capabilities: [170] Latency Tolerance Reporting
        Capabilities: [178] L1 PM Substates
        Kernel driver in use: r8169
        Kernel modules: r8169

Any clues as to how I can get this working in GbE mode?

ethtool enp5s0 | grep Speed

Cannot get wake-on-lan settings: Operation not permitted
        Speed: 100Mb/s

ethtool enp5s0 ...

Settings for enp5s0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes


  • It might help to know the actual NIC model. Please do sudo lspci -v and add the output related to the ethernet device to the question. May 22, 2020 at 15:06
  • Question amended
    – exharris
    May 22, 2020 at 15:12
  • 1
    Please provide Advertised link modes from the output of ethtool enp5s0
    – binarysta
    May 22, 2020 at 15:21
  • Question amended, thanks.
    – exharris
    May 22, 2020 at 15:47
  • Please don't cut output of the command to 1 line: it certainly did advertise at least 100baseT/Full but you didn't give the relevant lines.
    – A.B
    May 22, 2020 at 16:00

1 Answer 1


THis was happenning because in KDE Network Setting window, the 'Allow auto negotiation' setting was unticked, and speed was set to 100Mbps.

  • Good! it can be done with sudo ethtool -s enp5s0 autoneg on
    – binarysta
    May 22, 2020 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .