I'm running Linux Mint, version 19 Tara.

My battery life is really bad right now and my fan is always on because my computer is constantly at 70% CPU usage on this kworker thread. It's really starting to annoy me. I run top as soon as I boot up and before I even open a single program (other than the terminal), this process is already taking up 70% CPU.

    5 root      20   0       0      0      0 I  66.1   0.0   1:27.86 kworker/0:0-kac

when I run htop it identifies the kworker thread as going back and forth between being called kacpi_notify and kacipid.

I tried editing grub to acpi=off but then my system boots to a black screen with a blinking underscore and that's it. Won't boot.

I upgraded my kernel, so I'm now running 5.3.0-51-generic. My research so far makes me think I might need to update my BIOS, but my computer manufacturer only provides a BIOS update in .exe form. I've downloaded the exe, but I don't know where to go from here.

Can anybody please help me?


I've been researching on this problem also. I've tried changing the BIOS settings and all kinds of tweaks. I finally came across this link (https://forum.manjaro.org/t/kworker-kacpid-cpu-100/131532) and it worked for a while. As I have been switching between Ubuntu, Mint and Win10, once the problem happens, it becomes consistent even when I switch/boot into all the OS's. Once I applied the above fix while in Ubuntu 20 then it goes away on every OS I boot into.

Well the problem came back today while I booted up with Mint 19.3. I figure that since the problem came from the interrupt handling in the ACPI area, how can I trigger an ACPI event in hope to "reset" the problem? I decided to try putting the machine to "Suspend" mode, wait for it to complete, then hit the mouse/keyboard to wake it up to see it it'll correct or re-initialize the ACPI handling. Bingo! When it wakes up, the CPU usage drops right back down to the less than 5% range.

This is not just a Linux issue, but when it happens, it happens when I boot into Windoz also. It also does not seem to be a manufacturer specific issue either. This might be a basic PC architecture/design issue. I suspect it may be the ACPI init routine that caused the CPU spike. There might be timing issues in setting up the ISR in handling the ACPI interrupts, so when the interrupts do occur, there's no handling or resetting of the INT, hence causing the INT keeps occurring. Hope this info may give the developers some new ideas to put in a fix for the problem.

I have not tested it long enough to say this works all the time, but it's worth trying.

Best regards, Jim C

My setup: HP Z220, i5-3470, 16G DDR3, nVidia Quadro K1200. Adata 960G SSD + WD 160G ATA HD, APC UPS connected to USB port, nVidia Quadro K-1200, IBM Model M keyboard (1989) and HP optical mouse on PS/2 input. Not the greatest, not for gaming, but an old reliable. ;-)

  • bless you for this answer, sir. suspending the system did not work, but the advice at the link you posted did: it appears that gpe13 was my problem. my computer is very old (bought it in 2012) so I'm assuming it's just an incompatibility with the BIOS and the new version of Mint I'm using. – Tica Sloth Jun 19 '20 at 22:57
  • It worked for my Dell Precision 3620 tower, thanks for the answer! – Samuel Li Oct 28 '20 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.