0

Well I´m new in linux and I´m pretty lost... My laptop is an asus with ryzen 5 and gpu RX560X, maybe is only a drivers issue, but i don't know how to get what i need. Thanks!

2
  • 1
    please provide more details, how do you trying shutdown? open terminal emulator and try sudo shutdown -k now(if you are not root)
    – user413666
    May 20, 2020 at 23:11
  • I tried with shutdown command and normally with hte button of Mint, in both the OS is shutting down but the laptop still ON with the screen in black. I tried shutdown -k now but it doesn't appears to be doing anything...
    – Jaykooh
    May 21, 2020 at 9:23

2 Answers 2

1

Here is my personal experience:

I installed mint tricia 32-bit (xfce, kernel 5.4.0-77) on my old (OLD!) Samsung NC10 about 6 weeks ago, and it was fine.

Yesterday I switched it on for the first time in 5 weeks, did an update, and then it would not shut down through the standard shutdown button from the menu. I did shut it eventually by keeping the off-button pressed for a few seconds. I started it again. With the menu button it did not shut down, again, and by pressing the Esc key I could see the messages scrolled on the screen --- something like the following:

After "Shutdown" there was a "kernel panic",

"not syncing: Attempted to kill init!
/shutdown: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file ..."  

So I switched it off by holding the off-button, started it again, searched for the .so library (locate libpcre.so.3); I saw that there was one in /lib/i386-linux-gnu/ directory.

I just tried and copied it into a more standard path:

sudo cp /lib/i386-linux-gnu/libpcre.so.3 /usr/lib/

and then I tried to shut down through the menu button and it worked!

I tried once again, and it booted up fine and then shut down properly via the menu button. Hope this helps.

0

I've got the same problem with kernel 5.3.0-53. Kernel 5.3.0-51 works fine!

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.