0

The result of running startx shown below:
enter image description here

I’ve installed and used Debian 10 for a couple days now with no problems. Last night I began setting up vim, I downloaded a plugin manager as well as git. After taking a break, I came back to my computer and tried logging in again. I was not able to do this, login interface said I didn’t have authorization and it would not register my keyboard inputs. I held down the power button to turn it off and after about a minute I turned it back on. Much to my dismay, Debian did not boot up like it had in the past. Instead, its in a black screen that says “Debian GNU/Linux 10 Debian-workstation tty1” and the next lines says “Debian-workstation login:”.

I’ve tried updating using “apt-get update” but I get a lot of could not resolve and failed to fetch errors. This has happened even though I’m connected with an Ethernet. Also when it boots up there seems to be a problem with Avahi, it says “could not receive return value from daemon process”.

I’m a Linux noob, any help would be appreciated. Thanks.

Edit: I have read more about display manager. I was using Gnome before so I tried running the commands "systemctl status gdm" and "systemctl start gdm". For both of these I got "System has not been booted with systemd as init system (PID 1). Can't operate. Failed to connect to bus: Host is down".

  • Attached is the picture of the result of running startx @K7AAY – Willingtolearn May 19 at 18:32
  • @K7AAY do you have any ideas? – Willingtolearn May 19 at 22:55
  • Do you think this means I have to do a fresh install? @K7AAY – Willingtolearn May 19 at 23:05
  • @K7AAY That is not a terminal window, but a text-mode console. If the OP had gpm installed, mouse-copy-paste would still be possible, but that is quite a bold assumption for a newbie. To the OP: did you add anything to /etc/apt/sources.list or /etc/apt/sources.list.d/ directory, or install anything from sources outside the Debian 10 distribution? If you weren't careful, such outside sources might have caused package conflicts and apt may have ended up uninstalling important packages like gnome-session in an attempt to resolve them. – telcoM May 20 at 6:37
  • @telcoM I am in a text-mode console and I do not think a can copy-paste. Yes, I altered the source list and I downloaded a plugin manager from github for vim. I watched a video that said that some mirrors are faster than others so I altered the source list to correspond to these faster mirrors. – Willingtolearn May 20 at 13:49
1

If all you did was installing packages intended for another Linux distribution, the good news is that the system should be very much fixable. All your configuration files should still be present, so if you can get the packages back the way they were before the mishap, the system should be back in working order.

On the other hand, if you only used the system for a few days before the mishap, it might be still easier to mount an USB stick, copy all your data files (basically anything in your /home directory tree if you're uncertain) to the USB stick, and then reinstall.


To mount an USB stick without any GUI tools: First, before plugging in the USB stick, run cat /proc/partitions. Then plug in the stick and run the same command again. The output after plugging in the USB stick should have about two more lines - those will identify the device name of the USB stick and its partition. For example, if plugging in the stick caused two devices named sdc and sdc1 to appear, run mount /dev/sdc1 /mnt. Now the USB stick should be accessible under /mnt.

To make a compressed archive of anything under /home, you might do something like this:

tar jcvf /mnt/saved-home.tar.bz2 /home

Before unplugging the USB stick, run cd /; umount /mnt.


But if you want to try fixing the problem, read on...

The first step should probably be to undo your changes to the source list. If you don't know what to put in there, the following lines should be a good universal starting point for Debian 10:

deb http://deb.debian.org/debian buster main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free

If you want to explicitly use a repository that is geographically close to you, see the list of Debian mirrors.

But it sounds like the package conflicts caused the system to uninstall one or more packages that are essential for the network connection to work. As a result, you might have to use your installation media as a local package repository to get those essential packages back before you can get anything from network.

If your installation media is a CD/DVD, just insert the disc and run apt-cdrom add. It should auto-detect the installation media in the CD drive and register it as usable with apt.

If your installation media is a USB stick, plug it in, mount it e.g. under /mnt (see above) and run apt-cdrom -d /mnt add.

/var/log/dpkg.log is a text file that should have a timestamped record of all the recent package management operations (i.e. within a month or so), and /var/log/dpkg.log.1, if it exists, has the same information from the previous month.

You should find any packages that got uninstalled in the mishap and re-install them, with apt install <package-name>. You may want to check the list of metapackages at packages.debian.org and first install any metapackages that got uninstalled.

A metapackage is basically an empty package with a set of dependencies to packages related to a particular task or other logical group. For example, if you re-install metapackage gnome-core, then gnome-session and gdm3, that might restore at least rudimentary GUI functionality. That should allow you to get a package manager and /var/log/dpkg.log on the screen simultaneously, and reinstalling the rest of removed packages should be easier.

| improve this answer | |
  • Thank you so much. I put the install cd in and installed gnome like the sequence above. The display came back after I hit startx and rebooted the pc. Thanks again! – Willingtolearn May 21 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.