0

I'm trying to make hardware 3d acceleration works on Funtoo, but with minimum use flags enabled as possible.

Now I'm testing Funtoo on a RX Vega 54, but I have other computers with others vendors' cards that I'll try later.

When I boot on Ubuntu, all glxgears, glmark2 and glmark2-es2 gives around 8000 FPS, on Funtoo there is no glmark2 but glxgears gives about 600 FPS, when chroot to Ubuntu over Funtoo kernel and xorg-drivers it gives about 1600 FPS on glxgears and 400 FPS on glmark2-es2, but glmark2 doesn't even work.

I belive the problem is the renderer, running glxinfo | fgrep 'renderer string' gives the following result:

  • Ubuntu booted: OpenGL renderer string: Radeon RX Vega (VEGA10, DRM 3.33.0, 5.3.0-51-generic, LLVM 10.0.0)
  • Funtoo booted: OpenGL renderer string: Software Rasterizer
  • Ubuntu chrooted on Funtoo booted: OpenGL renderer string: llvmpipe (LLVM 10.0.0, 128 bits)

Configuration (make.conf and package.use)

Some other metrics

Look, the challenge is not being able to enable any use flag globally, if one is strictly required only the minimum set of packages should be configured.

0

it looks like you have not enabled hardware acceleration on Funtoo.

You should take a look on Funtoo instructions for the open-source amd drivers. It shows the set of kernel configuration settings needed to be able to properly compile as modules and use those drivers.

You can find a link here: Package:Radeon Video Drivers

In a nutshell: if kernel is already properly compiled you need to emerge the Radeon-ucode or linux-firmware packages as well as xf86-video-ati package.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.