I just purchased a brand new laptop: Gaming Asus TUF A15 FX506II-AL022, AMD Ryzen 7 4800H, 8GB DDR4, SSD 512GB (nvme), NVIDIA GeForce GTX 1650 Ti 4GB.I installed Mint Cinnamon 19.3--the latest as of today, and did all updates from a USB stick. When it first booted into GUI it said:

Your system is currently running without video hardware acceleration

So, I went ahead and tried to update drivers, but nothing was found.

I then proceeded and set it up, installed Skype, Zoom, mc, double commander, keepass, remmina with RDP plugin (hopefully I didn't miss anything). Finally, I did a restart and got this error from the title:

ucsi_acpi USBC000:00: PPM init failed (-110)

I did Alt + F1 to get into a working Command-line interface. Then, I rebooted and went into the boot menu, then recovery mode. I didn't see anything that would help, so then I just went with "resume" and it loaded up just fine in GUI, again showing the message with no "video hardware acceleration".

So I assume the problem is caused by some video driver. So basically I have 2 questions, assuming the problem is caused by the video driver:

  1. How can I get some updated drivers for my nvidia card?

  2. if above cannot be solved, how can I disable the driver so that I won't have to go into recovery mode and resume every time I reboot?

If my assumption is wrong, what else could cause this, and how to fix it?

Thank you.

4 Answers 4


I have the ASUS TUF A17 and have been struggling with it for about a week now but FINALLY have it working flawlessly.

First off, a lot of work has been done on the Linux Kernel between versions 5.6 - 5.8 in regards to the new AMD chips in both the Renoir GPU capabilities as well as fan & power control etc. So it's worth updating if you're savvy. If you're nervous about it, 5.8 will probably be pushed to most distros in October (like Ubuntu 20.04 & 20.10).

The error you're receiving is related to the USB-C port with Display Port capabilities.

  1. Install the Nvidia 440 driver. In Ubuntu this can be done via

    sudo apt-get install nvidia-driver-440

    However it doesn't appear Mint packages this driver bundle and that PPA another user suggested will most likely only have packages for Ubuntu.

    So let's install from Nvidia's package directly (this is what I did after upgrading the Linux kernel to 5.7.8, since Ubuntu's altered version of Nvidia's drivers may be optimized for the 5.4 kernel)

    wget http://us.download.nvidia.com/XFree86/Linux-x86_64/440.100/NVIDIA-Linux-x86_64-440.100.run
    chmod +x NVIDIA-Linux-x86_64-440.100.run
    sudo sh NVIDIA-Linux-x86_64-440.100.run

    Follow the prompts to complete installation but DON'T restart right away afterwards. We need to setup xorg so that the Nvidia driver boots correctly and we don't hang on the PPM init error again.

  2. First, if you have a xorg.conf file at /etc/X11/xorg.conf remove it.

    sudo rm /etc/X11/xorg.conf
  3. Now edit our 2 graphic driver xorg.d files (admgpu+nvidia)

    cd /usr/share/X11/xorg.conf.d/
    ls -al # to view the contents of our directory

    You should see a file for amdgpu & nvidia (among others).

    Let's edit the amdgpu file first (this is usually named 10-amdgpu.conf)

    sudo nano 10-amdgpu.conf

    Add the PrimaryGPU line

    Section "OutputClass"
        Identifier "AMDgpu"
        MatchDriver "amdgpu"
        Driver "amdgpu"
        Option "PrimaryGPU" "no"

    Press Ctrl+X then y # to save and exit nano

    Now let's edit the Nvidia file (usually 10-nvidia.conf, but I noticed Ubuntu named it something different, so I renamed it to 10-nvidia.conf)

    sudo nano 10-nvidia.conf # or other filename

    Add the Options and Module path

    Section "OutputClass"
       Identifier "nvidia"
       MatchDriver "nvidia-drm"
       Driver "nvidia"
       Option "AllowEmptyInitialConfiguration"
       Option "PrimaryGPU" "yes"
       ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
  4. Reboot your machine. You can plug in a USB-C-to-DP (Display Port)/HDMI cable at this point if you'd like.

Let me know if you run into any issues!


I got my Asus TUF A15 working under Ubuntu Studio 20.04 LTS by installing the nvidia-driver-440 (automatically fallen into 450 version) driver, but after some days messing around with the laptop, I realized that some programs were having serious issues with graphics. Games' performance (few, I don't use to play games) was even much poorer than any former experience with Nouveau driver on other hardware, and Wine didn't show any window at all, freezing the foreground screen (just after suggesting, in the command line, going back to nouveau driver). I use Wine for some windows VST instruments, so this was an important issue to be solved.

But as nouveau driver does not work at all in the A15, I had to manage this using nvidia, so I purged all nvidia* stuff, reinstalled xserver-xorg-video-nouveau, rebootg (no graphics, only command line after a lot of error messages), and then installed the nvidia-driver-390 (before, I got sure this will not fall automatically into 450 version, just paying attention to the newly installable packages. Be aware of transition packages that can lead your installation to later drivers, so check carefully the package to be installed. you can type apt-cache search nvidia-driver to see which ones are available, and which of them are transitional).

This, at least up to now, works fine, games have an acceptable performance and Wine works fine. The only thing I couldn't recover 100% was the nvidia-settings tool, which opens as an empty window with just two buttons: Help and Exit.



Since this should work on a default installation, I have filed a bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1912509

Please add info when you can, confirm it, etc where possible. It seems the nvidia driver installation fixes the issue but Ubuntu only supports the Nouveau driver officially. As such, let's supply information developers need to make this work with pure open source software, which may be a nouveau driver bugfix.

Until this is fixed refer to the solutions people have posted here for installing the nvidia driver. thank you Note that with my Asus Tuf 15 i5-10300H I had no issue with the 5.4 kernel, only with the 5.8 kernel that I got after an update (but that freezes occasionally). Others have posted solutions to install other kernels before 5.8, which may work too.


The problem is most likely missing NVIDIA-driver. I did also get the ucsi_acpi USBC000:00: PPM init failed (-110) error. Finally I succeded in installing the driver and got rid of the error.

First, open up a terminal window. Then use these commands:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update

sudo apt upgrade

sudo apt install nvidia-driver-VERSION_NUMBER_HERE

(in my case : sudo apt install nvidia-driver-430 or 440 , dont remember which one it was. nvidia-smi tells me version 440)

Restart the computer. Hopefully the error has gone away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .